适用产品和版本

适用于V600R008C10及以后版本的NE40E/ME60系列产品。

组网需求

在传统的单BRAS接入用户的场景下,一旦出现链路、节点故障,所有用户的业务都会中断,业务恢复的时间也不确定。采用双机备份的部署方法,可以从业务可靠性的层次提升网络的可靠性。在网络发生故障的情况下备用BRAS能够快速接管用户业务,使得用户感知不到网络的故障,继续使用网络资源。如图1-10所示,两台BRAS分别旁挂到P路由器上,BRAS1和BRAS2相互热备,包括BAS的相互热备和NAT的相互热备,为整个网络实现如下功能:

  • 提供家庭ADSL用户PPPOE拨号接入(包括IPv4和IPv6)认证计费,分配私网地址。当用户访问internet时,BRAS进行NAT转换。

  • 提供小企业用户三层BAS接入的认证和计费,配置静态路由指向企业内部,并为企业访问internet提供NAT转换。

  • 给IPTV用户提供DHCP Server,对下层PE Relay的STB DHCP请求,提供地址分配和认证。

图1-10  配置BAS叠加NAT双机热备组网图

表1-22  网络规划数据

配置思路

  1. 要求将下层用户的流量,尽量均匀的分布到两个BRAS上,因此需要进行BRAS1和BRAS2的相互热备。

  2. BRAS1和BRAS2需要支持HA的相互热备,下层用户的上网流量,相对均匀地到两个BRAS进行NAT转换。正常情况下,下层用户BAS主用BRAS1时,NAT也主用BRAS1。

  3. 配置路由,使对于BRAS1 NAT主用的用户,其Internet回程流量按照IGW-P1–BRAS1的路径进行转发。

操作步骤

1. 配置BAS双机热备

# 配置BRAS1。

#

//配置地址池(ipv4_hsi_1在BRAS1上为主用,ipv4_hsi_2在BRAS1上为备用)

#

ip pool ipv4_hsi_1 baslocal

gateway 10.1.0.1 255.255.128.0

section 0 10.1.0.2 10.1.127.254

dns-server 172.16.3.3 192.168.8.8

#

ip pool ipv4_hsi_2 baslocal rui-slave

gateway 10.1.128.1 255.255.128.0

# LOCAL

section 0 10.1.128.2 10.1.255.254

# REMOTE

dns-server 172.16.3.3 192.168.8.8

#

//配置接口

#

interface LoopBack1

description for RUI

ip address 10.1.1.11 255.255.255.255

#

interface Eth-Trunk1

description to P1 Eth-trunk 11 for access

mode lacp-static

#

interfaceEth-Trunk1.4000

vlan-type dot1q 4000

description for BRAS RUI

ip address 10.0.253.2 255.255.255.248

vrrp vrid 3 virtual-ip 10.0.253.1

admin-vrrp vrid 3

vrrp vrid 3 priority 120

vrrp vrid 3 preempt-mode timer delay 120

vrrp vrid 3 track interface Eth-Trunk3.1 reduced50  //监视接口状态

vrrp vrid 3 track bfd-session 2 peer  //监视BFD会话状态

vrrp vrid 3 track service-location 1 reduced50  //监视service-location备份组的状态

#

interface Eth-Trunk2

description to P1 Eth-trunk 12 for access

mode lacp-static

#

interface Eth-Trunk2.4000

vlan-type dot1q 4000

description for BRAS RUI

ip address 10.0.253.10 255.255.255.248

vrrp vrid 4 virtual-ip 10.0.253.9

admin-vrrp vrid 4

vrrp vrid 4 preempt-mode timer delay 120

vrrp vrid 4 track interface Eth-Trunk3.1reduced 50

vrrp vrid 4 track bfd-session 10 peer

vrrp vrid 4 track service-location 2 reduced50

#

interface Eth-Trunk4

description to BRAS2 Eth-trunk 4

ip address 10.1.1.1 255.255.255.248

#

//配置路由

#

ospf 1 router-id10.1.1.11

area 0.0.0.0

network 10.1.1.0 0.0.0.7

network 10.1.1.11 0.0.0.0

#

//配置BFD会话

#

bfd bras_rui_1 bindpeer-ip 10.0.253.3

discriminator local 2

discriminator remote 3

min-tx-interval 100

min-rx-interval 100

commit

#

bfd bras_rui_2 bindpeer-ip 10.0.253.11

discriminator local 10

discriminator remote 11

min-tx-interval 100

min-rx-interval 100

commit

#

//配置RBS和RBP

#

remote-backup-service s1

peer 10.1.1.12 source 10.1.1.11 port 2046

track interface Eth-Trunk3

protect redirect ip-nexthop 10.1.1.2 interfaceEth-Trunk4

ip-pool ipv4_hsi_1 metric 10  //配置地址池的cost值,主用的cost值较小

ip-pool ipv4_hsi_2 metric 20

#

remote-backup-profile p1

service-type bras

backup-id 10 remote-backup-service s1

peer-backup hot

vrrp-id 3 interface Eth-Trunk1.4000

nas logic-ip 10.51.250.250

#

remote-backup-profile p2

service-type bras

backup-id 20 remote-backup-service s1

peer-backup hot

vrrp-id 4 interface Eth-Trunk2.4000

nas logic-ip 10.51.250.250

#

//配置域

#

aaa

domain abc.com

authentication-scheme radius

accounting-scheme radius

ip-pool ipv4_hsi_1

ip-pool ipv4_hsi_2

dns primary-ip 172.16.3.3

dns second-ip 192.168.8.8

radius-server group aaa

trust upstream default

qos rate-limit-mode car inbound

qos rate-limit-mode car outbound

user-priority upstream trust-8021p-outer

#

//配置BAS接口

#

interface Eth-Trunk1.1

pppoe-server bind Virtual-Template 1

description for Home HSI user access 1

user-vlan 1001 1030 qinq 10

remote-backup-profile p1

bas

#

access-type layer2-subscriber default-domainauthentication abc.com

client-option82

option82-relay-mode dslam config-identify

ip-trigger

arp-trigger

#

#

interface Eth-Trunk2.1

pppoe-server bind Virtual-Template 1

description for home HSI user access 2

user-vlan 1031 1073 qinq 10

remote-backup-profile p2

bas

#

access-type layer2-subscriber default-domainauthentication abc.com

client-option82

option82-relay-mode dslam config-identify

ip-trigger

arp-trigger

#

#

# 配置BRAS2。

#

//配置地址池(ipv4_hsi_1在BRAS1上为主用,ipv4_hsi_2在BRAS1上为备用)

#

ip pool ipv4_hsi_1 bas localrui-slave

gateway 10.1.0.1 255.255.128.0

# LOCAL

section 0 10.1.0.2 10.1.127.254

# REMOTE

dns-server 172.16.3.3 192.168.8.8

#

ip pool ipv4_hsi_2 baslocal

gateway 10.1.128.1 255.255.128.0

section 0 10.1.128.2 10.1.255.254

dns-server 172.16.3.3 192.168.8.8

#

//配置接口

#

interface LoopBack1

description for RUI

ip address 10.1.1.12 255.255.255.255

#

interface Eth-Trunk1

description to P2 Eth-trunk 11 for access

mode lacp-static

#

interfaceEth-Trunk1.4000

vlan-type dot1q 4000

description for BRAS RUI

ip address 10.0.253.3 255.255.255.248

vrrp vrid 3 virtual-ip 10.0.253.1

admin-vrrp vrid 3

vrrp vrid 3 preempt-mode timer delay 120

vrrp vrid 3 track interface Eth-Trunk3.1reduced 50  //监视接口状态

vrrp vrid 3 track bfd-session 3 peer  //监视BFD会话状态

vrrp vrid 3 track service-location 1 reduced50  //监视service-location备份组的状态

#

interface Eth-Trunk2

description to P2 Eth-trunk 12 for access

mode lacp-static

#

interfaceEth-Trunk2.4000

vlan-type dot1q 4000

description for BRAS RUI

ip address 10.0.253.11 255.255.255.248

vrrp vrid 4 virtual-ip 10.0.253.9

admin-vrrp vrid 4

vrrp vrid 4 priority 120

vrrp vrid 4 preempt-mode timer delay 120

vrrp vrid 4 track interface Eth-Trunk3.1reduced 50

vrrp vrid 4 track bfd-session 11 peer

vrrp vrid 4 track service-location 2 reduced50

#

interface Eth-Trunk4

description to BRAS1 Eth-trunk 4

ip address 10.1.1.2 255.255.255.248

#

//配置路由

#

ospf 1 router-id10.1.1.12

area 0.0.0.0

network 10.1.1.0 0.0.0.7

network 10.1.1.12 0.0.0.0

#

//配置BFD会话

#

bfd bras_rui_1 bindpeer-ip 10.0.253.2

discriminator local 3

discriminator remote 2

min-tx-interval 100

min-rx-interval 100

commit

#

bfd bras_rui_2 bindpeer-ip 10.0.253.10

discriminator local 11

discriminator remote 10

min-tx-interval 100

min-rx-interval 100

commit

#

//配置RBS和RBP

#

remote-backup-service s1

peer 10.1.1.11 source 10.1.1.12 port 2046

track interface Eth-Trunk3

protect redirect ip-nexthop 10.1.1.1 interfaceEth-Trunk4

ip-pool ipv4_hsi_1 metric 20  //配置地址池的cost值,主用的cost值较小

ip-pool ipv4_hsi_2 metric 10

#

remote-backup-profile p1

service-type bras

backup-id 10 remote-backup-service s1

peer-backup hot

vrrp-id 3 interface Eth-Trunk1.4000

nas logic-ip 10.51.250.250

#

remote-backup-profile p2

service-type bras

backup-id 20 remote-backup-service s1

peer-backup hot

vrrp-id 4 interface Eth-Trunk2.4000

nas logic-ip 10.51.250.250

#

//配置域

#

aaa

domain abc.com

authentication-scheme radius

accounting-scheme radius

ip-pool ipv4_hsi_1

ip-pool ipv4_hsi_2

dns primary-ip 172.16.3.3

dns second-ip 192.168.8.8

radius-server group aaa

trust upstream default

qos rate-limit-mode car inbound

qos rate-limit-mode car outbound

user-priority upstream trust-8021p-outer

#

//配置BAS接口

#

interface Eth-Trunk1.1

pppoe-server bind Virtual-Template 1

description for Home HSI user access 1

user-vlan 1001 1030 qinq 10

remote-backup-profile p1

bas

#

access-type layer2-subscriber default-domainauthentication abc.com

client-option82

option82-relay-mode dslam config-identify

ip-trigger

arp-trigger

#

#

interface Eth-Trunk2.1

pppoe-server bind Virtual-Template 1

description for home HSI user access 2

user-vlan 1031 1073 qinq 10

remote-backup-profile p2

bas

#

access-type layer2-subscriber default-domainauthentication abc.com

client-option82

option82-relay-mode dslam config-identify

ip-trigger

arp-trigger

#

#

2.  配置NAT双机热备

# 配置BRAS1。

#

//配置用户组

#

user-group hsi_1

user-group hsi_2

#

//配置ACL规则

#

acl number 3001

rule 5 permit ip source 10.1.0.0 0.0.255.255

rule 10 permit ip source 10.5.0.0 0.0.255.255

#

acl number 6001

rule 0 permit ip source user-group hsi_1

#

acl number 6002

rule 0 permit ip source user-group hsi_2

#

//配置流分类、NAT动作和NAT引流策略,并应用NAT引流策略

#

traffic classifierhsi_nat operator or

if-match acl 6001

traffic classifierhsi2_nat operator or

if-match acl 6002

#

traffic behavior hsi_nat

nat bind instance hsi

traffic behaviorhsi2_nat

nat bind instance hsi2

#

traffic policy hsi_nat

share-mode

classifier hsi_nat behavior hsi_nat

classifier hsi2_nat behavior hsi2_nat

#

traffic-policy hsi_natinbound

#

//配置接口

#

interface Eth-Trunk4

description to BRAS2 Eth-trunk 4

ip address 10.1.1.1 255.255.255.248

vrrp vrid 1 virtual-ip 10.1.1.3

admin-vrrp vrid 1 ignore-if-down

vrrp vrid 1 priority 120

vrrp vrid 1 preempt-mode timer delay 120

vrrp vrid 1 track interface Eth-Trunk3.1reduced 50

vrrp vrid 1 track service-location 1 reduced50

vrrp vrid 2 virtual-ip 10.1.1.4

admin-vrrp vrid 2 ignore-if-down

vrrp vrid 2 track service-location 2 reduced50

ospf cost 5

#

//配置HA热备份功能

#

service-ha hot-backupenable

#

service-location 1

location slot 8 engine 0

remote-backup interface Eth-Trunk4 peer10.1.1.2  //对端设备的IP地址必须是与BRAS2相连接口的IP地址

vrrp vrid 1 interface Eth-Trunk4

service-location 2

location slot 8 engine 0

remote-backup interface Eth-Trunk4 peer10.1.1.2  //对端设备的IP地址必须是与BRAS2相连接口的IP地址

vrrp vrid 2 interface Eth-Trunk4

#

service-instance-grouphsi

service-location 1

service-instance-grouphsi2

service-location 2

#

//配置NAT实例

#

nat instance hsi id 1

port-range 2048

service-instance-group hsi  //绑定HA实例组

nat address-group 1 group-id 1

section 0 10.1.2.0 mask 23

nat outbound 3001 address-group 1

nat session-limit total 200

nat port-limit tcp 2048

nat port-limit udp 2048

nat alg all

nat filter mode full-cone

nat log session enable

nat instance hsi2 id 2

port-range 2048

service-instance-group hsi2

nat address-group 1 group-id 1

section 0 10.1.3.0 mask 23

nat outbound 3001 address-group 1

nat session-limit total 200

nat port-limit tcp 2048

nat port-limit udp 2048

nat alg all

nat filter mode full-cone

nat log session enable

#

//配置域,在域下将NAT实例和用户组绑定

#

aaa

domain abc.com

user-group hsi_1 bind nat instance hsi

user-group hsi_2 bind nat instance hsi2

#

# 配置BRAS2。

#

//配置用户组

#

user-group hsi_1

user-group hsi_2

#

//配置ACL规则

#

acl number 3001

rule 5 permit ip source 10.1.0.0 0.0.255.255

rule 10 permit ip source 10.5.0.0 0.0.255.255

#

acl number 6001

rule 0 permit ip source user-group hsi_1

#

acl number 6002

rule 0 permit ip source user-group hsi_2

#

//配置流分类、NAT动作和NAT引流策略,并应用NAT引流策略

#

traffic classifierhsi_nat operator or

if-match acl 6001

traffic classifierhsi2_nat operator or

if-match acl 6002

#

traffic behavior hsi_nat

nat bind instance hsi

traffic behaviorhsi2_nat

nat bind instance hsi2

#

traffic policy hsi_nat

share-mode

classifier hsi_nat behavior hsi_nat

classifier hsi2_nat behavior hsi2_nat

#

traffic-policy hsi_natinbound

#

//配置接口

#

interface Eth-Trunk4

description to BRAS1 Eth-trunk 4

ip address 10.1.1.2 255.255.255.248

vrrp vrid 1 virtual-ip 10.1.1.3

admin-vrrp vrid 1 ignore-if-down

vrrp vrid 1 track service-location 1 reduced50

vrrp vrid 2 virtual-ip 10.1.1.4

admin-vrrp vrid 2 ignore-if-down

vrrp vrid 2 priority 120

vrrp vrid 2 preempt-mode timer delay 120

vrrp vrid 2 track interface Eth-Trunk3.1reduced 50

vrrp vrid 2 track service-location 2 reduced50

ospf cost 5

#

//配置HA热备功能

#

service-ha hot-backupenable

#

service-location 1

location slot 8 engine 0

remote-backup interface Eth-Trunk4 peer10.1.1.1  //对端设备的IP地址必须是与BRAS1相连接口的IP地址

vrrp vrid 1 interface Eth-Trunk4

service-location 2

location slot 8 engine 0

remote-backup interface Eth-Trunk4 peer10.1.1.1  //对端设备的IP地址必须是与BRAS1相连接口的IP地址

vrrp vrid 2 interface Eth-Trunk4

#

service-instance-grouphsi

service-location 1

service-instance-grouphsi2

service-location 2

#

//配置NAT实例

#

nat instance hsi id 1

port-range 2048

service-instance-group hsi  //绑定HA实例组

nat address-group 1 group-id 1

section 0 10.1.2.0 mask 23

nat outbound 3001 address-group 1

nat session-limit total 200

nat port-limit tcp 2048

nat port-limit udp 2048

nat alg all

nat filter mode full-cone

nat log session enable

nat instance hsi2 id 2

port-range 2048

service-instance-group hsi2

nat address-group 1 group-id 1

section 0 10.1.3.0 mask 23

nat outbound 3001 address-group 1

nat session-limit total 200

nat port-limit tcp 2048

nat port-limit udp 2048

nat alg all

nat filter mode full-cone

nat log session enable

#

//配置域,在域下将NAT实例和用户组绑定

#

aaa

domain abc.com

user-group hsi_1 bind nat instance hsi

user-group hsi_2 bind nat instance hsi2

#

3. 配置Internet路由

# 配置BRAS1

#

//配置接口

#

interface Eth-Trunk3

description to P1 Eth-trunk 13

#

interface Eth-Trunk3.1

vlan-type dot1q 1

description to eth-trunk13.1 for internet

ip address 10.1.1.21 255.255.255.252

#

interface Eth-Trunk4

description to BRAS2 Eth-trunk 4

ip address 10.1.1.1 255.255.255.248

ospf cost 5

#

//配置前缀列表

#

ip ip-prefix ipv4-hsiindex 10 permit 10.1.2.0 23 greater-equal 23 less-equal 32

ip ip-prefix ipv4-hsiindex 20 permit 10.1.3.0 23 greater-equal 23 less-equal 32

#

//配置路由策略

#

route-policy ipv4-hsipermit node 10

if-match ip-prefix ipv4-hsi

#

//使能自动控制路由cost优先级功能

#

peer-backup route-cost auto-advertising

#

//配置OSPF

#

ospf 1 router-id10.1.1.11

default cost inherit-metric

import-route unr type 1 route-policy ipv4-hsi

area 0.0.0.0

network 10.1.1.20 0.0.0.3

network 10.1.1.0 0.0.0.7

network 10.1.1.11 0.0.0.0

#

# 配置BRAS2

#

//配置接口

#

interface Eth-Trunk3

description to P2 Eth-trunk 13

#

interface Eth-Trunk3.1

vlan-type dot1q 1

description to eth-trunk13.1 for internet

ip address 10.1.1.31 255.255.255.252

#

interface Eth-Trunk4

description to BRAS2 Eth-trunk 4

ip address 10.1.1.2 255.255.255.248

ospf cost 5

#

//配置前缀列表

#

ip ip-prefix ipv4-hsiindex 10 permit 10.1.2.0 23 greater-equal 23 less-equal 32

ip ip-prefix ipv4-hsiindex 20 permit 10.1.3.0 23 greater-equal 23 less-equal 32

#

//配置路由策略

#

route-policy ipv4-hsipermit node 10

if-match ip-prefix ipv4-hsi

#

//使能自动控制路由cost优先级功能

#

peer-backup route-cost auto-advertising

#

//配置OSPF

#

ospf 1 router-id10.1.1.12

default cost inherit-metric

import-route unr type 1 route-policy ipv4-hsi

area 0.0.0.0

network 10.1.1.30 0.0.0.3

network 10.1.1.0 0.0.0.7

network 10.1.1.12 0.0.0.0

#

# 配置P1

#

//配置接口

#

interface Eth-Trunk13

description to BRAS1Eth-Trunk3

#

interface Eth-Trunk13.1

vlan-type dot1q 1

description toeth-trunk3.1 for internet

ip binding vpn-instanceHSI

ip address 10.1.1.22255.255.255.252

#

//配置OSPF

#

ospf 1 router-id 10.3.3.31vpn-instance HSI

description for HSI

default-route-advertisepermit-calculate-other

area 0.0.0.0

network 10.1.1.200.0.0.3

#

//配置前缀列表

#

ip ip-prefix BRAS1-HSIindex 10 permit 10.1.2.0 23 greater-equal 23 less-equal 32

ip ip-prefix BRAS2-HSIindex 10 permit 10.1.3.0 23 greater-equal 23 less-equal 32

ip ip-prefix defaultindex 10 permit 0.0.0.0 0

#

//配置路由策略

#

route-policy to_igwpermit node 10

if-match ip-prefixBRAS1-HSI

apply community 100:3000

#

route-policy to_igwpermit node 20

if-match ip-prefix BRAS2-HSI

apply community 100:3000

#

route-policy default_inpermit node 10

if-match ip-prefixdefault

#

//配置BGP

#

bgp 65002

#

ipv4-family vpn-instanceHSI

import-route ospf 1

peer 10.1.1.41 as-number100

peer 10.1.1.41description to IGW

peer 10.1.1.41route-policy default_in import

peer 10.1.1.41route-policy to_igw export

peer 10.1.1.41advertise-community

#

#

# 配置P2

#

//配置接口

#

interface Eth-Trunk13

description to BRAS2Eth-Trunk3

#

interface Eth-Trunk13.1

vlan-type dot1q 1

description toeth-trunk3.1 for internet

ip binding vpn-instanceHSI

ip address 10.1.1.32255.255.255.252

#

//配置OSPF

#

ospf 1 router-id10.3.3.32 vpn-instance HSI

description for HSI

default-route-advertisepermit-calculate-other

area 0.0.0.0

network 10.1.1.300.0.0.3

#

//配置前缀列表

#

ip ip-prefix BRAS1-HSIindex 10 permit 10.1.2.0 23 greater-equal 23 less-equal 32

ip ip-prefix BRAS2-HSIindex 10 permit 10.1.3.0 23 greater-equal 23 less-equal 32

ip ip-prefix defaultindex 10 permit 0.0.0.0 0

#

//配置路由策略

#

route-policy to_igwpermit node 10

if-match ip-prefixBRAS1-HSI

apply community 100:3000

#

route-policy to_igwpermit node 20

if-match ip-prefixBRAS2-HSI

apply community 100:3000

#

route-policy default_inpermit node 10

if-match ip-prefixdefault

#

//配置BGP

#

bgp 65002

#

ipv4-family vpn-instanceHSI

import-route ospf 1

peer 10.1.1.43 as-number100

peer 10.1.1.43description to IGW

peer 10.1.1.43route-policy default_in import

peer 10.1.1.43route-policy to_igw export

peer 10.1.1.43advertise-community

#

#

4.  验证配置结果

# BAS信息查看

  • 执行命令displayaccess-user查看所有在线用户的信息。

  • 执行命令displayaccess-user domain domain-name查看某个域下在线用户的信息。

  • 执行命令displayaccess-user username username verbose查看某个用户的具体信息。

  • 执行命令displaybackup-user [ user-id user-id | username user-name ]查看备份用户信息。

# NAT信息查看

  • 执行命令display nat board-state查看NAT单板状态。

  • 执行命令display natsession-table size查看当前为各个业务板分配的会话表资源。

  • 执行命令display natsession aging-time查看NAT会话的老化时间。

  • 执行命令display natstatistics查看NAT单板的各类应用统计信息。

  • 执行命令display nataddress-usage查看地址池公网端口使用情况及使用率。

  • 执行命令display natuser-information查看已上线的NAT用户信息,热备时两边BRAS信息相同。

  • 执行命令display natsession table查看NAT会话表项。使用NAT热备时,两边BRAS能查看到相同的NAT表项。

双机热备_配置BAS叠加NAT双机热备示例相关推荐

  1. 双机热备_什么是高可用双机热备?双机热备概念原理详解

    双机热备是什么意思?为什么要用双机热备?双机热备有哪些种类?包含了哪些双机热备软件?下面就来简单地说说. 什么是双机热备? 从广义上讲,就是对于重要的服务,使用两台服务器,互相备份,共同执行同一服务. ...

  2. windows文件服务器双机热备_实战教程:如何建立双机热备系统

    [IT168资讯]笔者是一名医院的网管,而医院的软件系统要求能够做到一周7×24小时工作,对于整个系统的核心服务器来说如果死机后果是灾难性的.所以采用网络服务器容错技术来保障计算机系统的可靠性是件大事 ...

  3. mysql双机数据热备份_配置MySQL数据库双机热备份

    1.mysql 数据库没有增量备份的机制,当数据量太大的时候备份是一个很大的问题.还好 mysql 数据库提供了一种主从备份的机制,其实就是把主数据库的所有的数据同时写到备份数据库中.实现 mysql ...

  4. Oracle 共享磁盘阵列 双机热备 实战 配置教程 配置手册

    Oracle 11g共享存储双机热备配置手册 本文介绍 通过ServHA Cluster配置Oracle共享磁盘阵列双机容错集群. 集群软件下载地址:http://www.microcolor.net ...

  5. mysql主备数据库配置文档_MySQL数据库配置主从服务器实现双机热备实例教程

    网站:bbs.osyunwei.com 程序在:Web服务器192.168.21.129上面 数据库在:MySQL服务器192.168.21.169上面 实现目的:增加一台MySQL备份服务器(192 ...

  6. oracle12c双机热备方案,Oracle 共享磁盘阵列 双机热备 实战 配置教程 配置手册

    Oracle 11g共享存储双机热备配置手册 本文介绍 通过ServHA Cluster配置Oracle共享磁盘阵列双机容错集群. 主要步骤: 一.防火墙配置. 二.安装Oracle  11g. 三. ...

  7. lvs+keepalived实现lvs nat模式热备配置

    lvs nat模式LB热备配置网上几乎找不到相关文档,找到几个但都不靠谱,做LB主备切换时都会出现问题,无奈方案之急需,自己参考研究半天,终于用lva+keepalived获得成功,现分享一下 环境: ...

  8. 双机热备的缺点_弱电工程中的双机热备是什么?带你了解服务器双机热备

    双机热备知多少? 问:能解释一下什么是双机热备吗?答:所谓双机热备,就是将中心服务器安装成互为备份的两台服务器,并且在同一时间内只有一台服务器运行.当其中运行着的一台服务器出现故障无法启动时,另一台备 ...

  9. 双机热备_磁盘阵列柜

    双机热备这一概念包括了广义与狭义两种意义. 从广义上讲,就是对于重要的服务,使用两台服务器,互相备份,共同执行同一服务.当一台服务器出现故障时,可以由另一台服务器承担服务任务,从而在不需要人工干预的情 ...

最新文章

  1. go io.reader 多次读取_Go 语言进阶:freecache 源码学习(1)
  2. Android 面试 - compileSdkVersion、minSdkVersion、targetSdkVersion、buildToolsVersion
  3. 【二叉树】【144. 二叉树的前序遍历】【中等】
  4. 第八周结对编程四则运算二
  5. linux下使用VS CODE + CMAKE 调试C++程序
  6. Visual.Assist.X.V10.7.1949的汉化破解补丁
  7. mysql数据备份在哪里_mysql之数据备份与恢复
  8. 寂寞的hasLayout
  9. JavaScript单线程和浏览器事件循环简述
  10. Clion配置Toolchains
  11. java 泛型 class t_java 泛型中classT 和T的区别是什么?
  12. Pycharm报错解决:error:please select a valid Python interpreter 及一些基本设置
  13. Gradient Descent(机器学习之梯度下降法)
  14. 1、varargout与nargout区别
  15. 算法笔记-二分查找和二分答案
  16. 使用FreeImage保存彩图,灰度图
  17. html5橡皮擦,HTML5 Canvas笔记——实现橡皮擦功能,包括矩形擦和圆形擦。
  18. 数字音频信号--Dither
  19. obs 推流编码在哪设置_OBS Studio基本设置
  20. CG中DCC什么是?

热门文章

  1. ios实现图片动画效果
  2. Hls之播放遇到的坑
  3. linux服务器知识学习:linux系统的目录结构
  4. openlayers 加载高德底图
  5. html事件绑定的方法,如何获取html元素所绑定的事件
  6. php laravel 理解,程序员-说一下PHP框架Laravel,如何理解她的思想
  7. php接口模式,PHP设计模式 - 流接口模式
  8. python 怎么算l2范数_python之彻底搞懂迭代、可迭代、迭代器的区别(一)
  9. java包名命名规则_告别编码5分钟,命名2小时!史上最全的Java命名规范参考!
  10. python的三种取整方式_python3.6 numpy 数组的多种取整方式