计算机网络原理实验(三)——小型校园网络模拟搭建

  • 前言
  • 基础知识
  • 拓扑图
  • 网络地址划分
  • 终端设备配置
  • 三层交换机配置
    • 查看配置后信息
  • 路由器A配置
    • 查看路由器A的配置
  • 路由器B
    • 路由器B的配置
  • 二层交换机配置
    • 二层交换机的配置
  • 服务器网页内容
  • 运行截图
  • 使用技巧
  • 心得体会

前言

  • 思科路由模拟器(Cisco Packet Tracer)模拟出pc若干;路由器两台;两层及三层交换机各一台,网线若干。

  • 网络信息:某学校有3个学院,学院A有网络用户50人,学院B有网络用户230人,学院C有500人,每个学院都有自己独立的楼宇,网络机房也属于独立楼宇,具有学校的web服务器。学校的可用Ip地址范围为4个C,、学校网络由一台三层交换机作为核心,学校出口有路由器A一台。要求模拟外网网络,外网网络用10.0.0.0/8模拟,采用一台互联网路由器B,路由器B下连接有模拟的web网络服务器和一个互联网用户,地址分别为10.0.255.254和10.0.254.254。

  • 根据网络信息,合理规划各个学院的网络,给出网络地址划分和分配表,设备配置和部署表,画出网络拓扑图,在三层交换机上建立符合网络需求的vlan并分配到接入交换机的端口下。每个学院下各模拟一个用户。要求三个用户之间能够互相通讯。从三层交换机到互联网web服务器之间的路由信息自行设计配置实现,要求用最少的地址实现。在互联网web服务器上开启web服务,最终实现在客户pc上能够访问web服务器,界面信息包含姓名全拼。在学校web服务器上开启web服务,最终实现学院客户pc以及互联网用户能够访问web服务器,并显示学校web信息。所有的访问用数据包模拟传输过程,并分析数据包经过各个设备的变化。

基础知识

拓扑图

网络地址划分

部门 vlan 网络地址 掩码 网关
学院A 2 192.168.1.128 255.255.255.192 192.168.1.129
学院B 3 192.168.2.0 255.255.255.0 192.168.2.1
学院C 4 192.168.3.0 255.255.255.0 192.168.3.1
学院C 5 192.168.4.0 255.255.255.0 192.168.4.1
管理地址 1 192.168.1.0 255.255.255.192 192.168.1.1

终端设备配置

主机名 ip 掩码 默认网关
学院A 192.168.1.130 255.255.255.192 192.168.1.129
学院B 192.168.2.2 255.255.255.0 192.168.2.1
学院C 192.168.3.2 255.255.255.0 192.168.3.1
PC3 10.0.254.254 255.255.0.0 10.0.0.1
服务器2 10.0.255.254 255.255.0.0 10.0.0.1
服务器3 192.168.1.10 255.255.255.192 192.168.1.1

三层交换机配置

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan 2
Switch(config-if)#ip address 192.168.1.129 255.255.255.192
Switch(config-if)#no shut
Switch(config-if)#int vlan 3
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#int vlan 4
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#int vlan 5
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#int fa0/1
Switch(config-if)#sw access vlan 2
Switch(config-if)#no shut
Switch(config-if)#int fa0/2
Switch(config-if)#sw access vlan 3
Switch(config-if)#no shut
Switch(config-if)#int fa0/3
Switch(config-if)#sw access vlan 4
Switch(config-if)#no shut
Switch(config-if)#int vlan 1
Switch(config-if)#ip address 192.168.1.1 255.255.255.192
Switch(config-if)#no shut
Switch(config-if)#int fa0/4
Switch(config-if)#sw access vlan 1
Switch(config-if)#no shut
Switch(config)#int fa0/23
Switch(config-if)#sw access vlan 1
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

查看配置后信息

// 省略!
Switch#sh run
Building configuration...
Current configuration : 1474 bytes
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname Switch
ip routing
spanning-tree mode pvst
interface FastEthernet0/1switchport access vlan 2
interface FastEthernet0/2switchport access vlan 3
interface FastEthernet0/3switchport access vlan 4
interface FastEthernet0/4
interface FastEthernet0/5
interface FastEthernet0/6
interface FastEthernet0/7
interface FastEthernet0/8
interface FastEthernet0/9
interface FastEthernet0/10
interface FastEthernet0/11
interface FastEthernet0/12
interface FastEthernet0/13
interface FastEthernet0/14
interface FastEthernet0/15
interface FastEthernet0/16
interface FastEthernet0/17
interface FastEthernet0/18
interface FastEthernet0/19
interface FastEthernet0/20
interface FastEthernet0/21
interface FastEthernet0/22
interface FastEthernet0/23
interface FastEthernet0/24
interface GigabitEthernet0/1
interface GigabitEthernet0/2
interface Vlan1ip address 192.168.1.1 255.255.255.192
interface Vlan2ip address 192.168.1.129 255.255.255.192
interface Vlan3ip address 192.168.2.1 255.255.255.0
interface Vlan4ip address 192.168.3.1 255.255.255.0
interface Vlan5no ip address
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.2
ip flow-export version 9
line con 0
line aux 0
line vty 0 4login
end

路由器A配置

Continue with configuration dialog? [yes/no]: no
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config-if)#int fa0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.192
Router(config-if)#no shut
Router(config-if)#int fa0/1
Router(config-if)#ip address 192.168.1.65 255.255.255.192
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1
Router(config)#ip route 0.0.0.0 0.0.0 192.168.1.66

查看路由器A的配置

Router#sh run
Building configuration...
Current configuration : 711 bytes
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname Router
ip cef
no ipv6 cef
interface FastEthernet0/0ip address 192.168.1.2 255.255.255.192duplex autospeed auto
interface FastEthernet0/1ip address 192.168.1.65 255.255.255.192duplex autospeed auto
router rip
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.2.0 255.255.255.0 192.168.1.1
ip route 192.168.3.0 255.255.255.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.66
ip flow-export version 9
line con 0
line aux 0
line vty 0 4login
end

路由器B

Continue with configuration dialog? [yes/no]: no
Router>en
Router#conf t
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.1.66 255.255.255.192
Router(config-if)#no shut
Router(config-if)#int fa0/1
Router(config-if)#ip address 10.0.0.1 255.255.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.1.65

路由器B的配置

Router#sh run
Building configuration...
Current configuration : 655 bytes
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname Router
ip cef
no ipv6 cef
interface FastEthernet0/0ip address 192.168.1.66 255.255.255.192duplex autospeed auto
interface FastEthernet0/1ip address 10.0.0.1 255.255.0.0duplex autospeed auto
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.1.65
ip route 192.168.2.0 255.255.255.0 192.168.1.65
ip route 192.168.1.0 255.255.255.0 192.168.1.65
ip flow-export version 9
line con 0
line aux 0
line vty 0 4login
end

二层交换机配置

Switch>en
Switch#conf t
Switch(config)#ip default-gateway 10.0.0.1
Switch(config)#int vlan 1
Switch(config-if)#ip address 10.0.0.2 255.255.0.0
Switch(config-if)#no shut
Switch(config-if)#int fa0/24
Switch(config-if)#sw access vlan 1
Switch(config-if)#no shut

二层交换机的配置

Switch#sh run
Building configuration...
Current configuration : 1039 bytes
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname Switch
spanning-tree mode pvst
interface FastEthernet0/1
interface FastEthernet0/2
interface FastEthernet0/3
interface FastEthernet0/4
interface FastEthernet0/5
interface FastEthernet0/6
interface FastEthernet0/7
interface FastEthernet0/8
interface FastEthernet0/9
interface FastEthernet0/10
interface FastEthernet0/11
interface FastEthernet0/12
interface FastEthernet0/13
interface FastEthernet0/14
interface FastEthernet0/15
interface FastEthernet0/16
interface FastEthernet0/17
interface FastEthernet0/18
interface FastEthernet0/19
interface FastEthernet0/20
interface FastEthernet0/21
interface FastEthernet0/22
interface FastEthernet0/23
interface FastEthernet0/24switchport mode access
interface Vlan1ip address 10.0.0.2 255.255.0.0
ip default-gateway 10.0.0.1
line con 0
line vty 0 4login
line vty 5 15login
end

服务器网页内容


运行截图


使用技巧

  • 显示端口
  • 做标记

心得体会

  • 不同的设备之间用直通线,相同的设备用交叉线(三层交换机有路由功能)
  • 不同设备的连接端口之间,最好处于同一个网络号下

计算机网络原理实验(三)——小型校园网络模拟搭建相关推荐

  1. 燕山大学计算机网络实验(windows网络配置方法及基本网络命令、交换机和路由器的使用、小型校园网络模拟搭建)

    项目源码以及报告获取,可看我专栏简介 实验1 windows网络配置方法及基本网络命令 1.1 实验内容和要求 1.查看本机网络配置,根据配置信息,把本机地址改为静态地址,并使用ipconfig.pi ...

  2. 计算机网络原理 实验2 《NS3路由模拟实验》

    计算机网络原理 实验2 <NS3 路由模拟实验> 一.实验目的 1.了解NS3网络模拟器的基本操作: 2.学习采用距离矢量算法(Distance Vector Algorithm)的动态路 ...

  3. 数据库原理实验三 数据库综合设计实验 实验报告

    实验三 数据库系统设计综合实验 1.实验目的通过实验,使学生掌握数据库系统设计和开发的一般方法,能够设计并实现简单的数据库系统. 2.实验要求熟悉实验室实验环境,掌握实验预备知识,了解实验中故障排除的 ...

  4. 计算机网络原理 大型实验,计算机网络原理实验 实验一

    <计算机网络原理实验 实验一>由会员分享,可在线阅读,更多相关<计算机网络原理实验 实验一(13页珍藏版)>请在人人文库网上搜索. 1.实验一 Wireshark的安装与使用一 ...

  5. 计算机课实验三,成都信息工程学院计算机网络课程实验三

    成都信息工程学院计算机网络课程实验三 本文关键词:成都,计算机网络,信息工程学院,课程,实验 成都信息工程学院计算机网络课程实验三 本文简介:计算机网络实验报告实验三:编写客户服务器程序班级xxxxx ...

  6. 计算机网络原理 实验1 《Windows Socket编程》

    计算机网络原理 实验1 <Windows Socket编程> 一.实验目的 通过实验,熟悉并掌握计算机Windows 编程的基本知识,进一步加深对课堂所学基本内容的理解,掌握基本的Wind ...

  7. 计算机网络原理 实验3 《IP数据包捕获及数据分析》

    计算机网络原理 实验3 <IP数据包捕获及数据分析> 一.实验目的 JPCAP是一个能够捕获.发送网络数据包的Java类库包.这个包用到了Winpcap/Libpcap和原始套接字API, ...

  8. 计算机网络云南大学实验四,云南大学软件学计算机网络原理实验四.doc

    云南大学软件学计算机网络原理实验四 实验四.web服务器套接字编程实验指导 1.实验目的: 编写一个WEB服务器程序,可以接受来自浏览器的访问,并传输页面(包含多个对象)到浏览器.掌握Socket编程 ...

  9. 广州大学人工智能原理实验三:产生式系统推理

    相关资料 广州大学人工智能原理实验一:知识的表示与推理实验 广州大学人工智能原理实验二:八数码问题 广州大学人工智能原理实验三:产生式系统推理 广州大学人工智能原理实验四:TSP问题的遗传算法实现 广 ...

最新文章

  1. 那些为“自主”的研发“
  2. golang 打印调用堆栈
  3. 处理一键安装LNMP环境之后,phpinfo.php打开不显示内容的问题
  4. mysql建立电影表_【代码片段】MySQL新建表添加基础字段
  5. VBA自定义函数集锦[2]
  6. scala学习笔记-基础语法(1)
  7. 【Splay】【块状链表】bzoj3223 Tyvj 1729 文艺平衡树
  8. java eclipse 注释模板_Eclipse Java注释模板设置详解
  9. 优秀编程网站收录集锦
  10. 实习一年算工作一年吗?_经过一年的努力,我如何找到软件工程工作
  11. Opencv undefined reference to `cv::imread() Ubuntu编译
  12. XCode 编辑器的shortcuts
  13. 【成功解决】Error:(3, 46) java: 程序包org.springframework.context.annotation不存在
  14. 思科模拟器:路由器基本配置
  15. 关于ESAPI无法打印debug级别日志
  16. angular 子父页面传值以及调用方法
  17. 双十一,程序员可太难了
  18. flask keras 多线程环境下加载模型
  19. 回车符号和换行符号产生背景
  20. 微信版“花呗”全面开放,人人都可以申请!

热门文章

  1. FFplay 播放器
  2. App集成ApplePay的一些资料整理
  3. 【模块电路】简单波形发生器
  4. 如何找到电影的下载链接
  5. ESP32设备驱动-L3GD20三轴角速率传感器驱动
  6. 树莓派学习笔记——yeelink 远程控制LED
  7. 雅思分数计算表和考试题型分析
  8. 微服务调用失败的一种解决方案
  9. PS制作麦克风质感图标,UI设计教程
  10. 小米手机玩转photoshop/魔兽世界,无需固定IP,实现内网穿透详细教程,及踩坑过程