EIGRP发布默认路由的四种方式
  • Redistributed default route

    #R1#
    router eigrp 100

    redistribute static

     network 10.1.1.1 0.0.0.0no auto-summary
    ip route 0.0.0.0 0.0.0.0 202.100.1.10
    

  • By using ip summary-address command

    #interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0

    ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5

  • Default route by using ip default-network command

    R1(config)#ip default-network 202.100.1.0(

    写成主类

    这样就可以把这条路由下发给其它的路由器当做默认路由了使用本命令要满足以下条件:
    1、接口IP地址必须是主类
    2、接口必须宣告进EIGRP
    3、使用命令下发时也必须写主类网络号

  • Default route with network 0.0.0.0 command

    R1#router eigrp 100network 1.1.1.1 0.0.0.0network 10.1.1.1 0.0.0.0network 0.0.0.0no auto-summaryip route 0.0.0.0 0.0.0.0 FastEthernet0/0(

    写下一跳不行,必须写接口

基本网络配置

R2#
interface FastEthernet0/0ip address 10.1.1.10 255.255.255.0

R1#
interface FastEthernet0/0ip address 202.100.1.1 255.255.255.0
interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 202.100.1.10

Interne#
interface FastEthernet0/0ip address 202.100.1.10 255.255.255.0
ip route 0.0.0.0 0.0.0.0 202.100.1.1

Redistributed default route配置

R1#
router eigrp 100

redistribute static

 network 10.1.1.1 0.0.0.0no auto-summary

验证

#R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static routeGateway of last resort is 10.1.1.1 to network 0.0.0.010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

D*EX 0.0.0.0/0 [170/307200] via 10.1.1.1, 00:17:42, FastEthernet0/0

#

Default route By using ip summary-address command配置

R1#
router eigrp 100network 10.1.1.1 0.0.0.0no auto-summary
interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0

ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5

验证

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static routeGateway of last resort is 10.1.1.1 to network 0.0.0.010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

D* 0.0.0.0/0 [90/284160] via 10.1.1.1, 00:00:05, FastEthernet0/0

Default route by using ip default-network command配置

  • The EIGRP default route can be created with the ip default-network network-number command. The classful destination network.

  • the network must either be an EIGRP-derived network in the routing table or be generated using a static route, which has been redistributed into EIGRP

  • the ip default-network command does not benefit router R1 directly.

R1#router eigrp 100network 10.1.1.1 0.0.0.0network 202.100.1.0no auto-summary

ip default-network 202.100.1.0

ip route 0.0.0.0 0.0.0.0 202.100.1.10

验证

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 202.100.1.0

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 10.1.1.1, 00:04:01, FastEthernet0/0

D* 202.100.1.0/24 [90/307200] via 10.1.1.1, 00:00:14, FastEthernet0/0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

Default route with network 0.0.0.0 command配置

if the network 0.0.0.0 command is added to the EIGRP configuration, it redistributes a default route as a result of the ip route 0.0.0.0 0.0.0.0 interface command.
R1#router eigrp 100
 network 1.1.1.1 0.0.0.0network 10.1.1.1 0.0.0.0

network 0.0.0.0

 no auto-summary

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

验证

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 10.1.1.1, 00:10:37, FastEthernet0/0
D    202.100.1.0/24 [90/307200] via 10.1.1.1, 00:00:30, FastEthernet0/010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

D* 0.0.0.0/0 [90/307200] via 10.1.1.1, 00:00:02, FastEthernet0/0

来自为知笔记(Wiz)

转载于:https://www.cnblogs.com/faerl/p/8253740.html

lab 2 EIGRP Default Route相关推荐

  1. Default Route

    背景需求 如下图所示的网络拓扑中,展示了一个企业的网络: GW1.GW2及GW3是该企业各个站点的网关路由器,这些路由器各下联一台以太网交换机,同时上联出口路由器OR. 以太网交换机连接着终端用户,出 ...

  2. CCNA配置试验之三 EIGRP协议的配置

    EIGRP协议概述 EIGRP是最典型的平衡混合路由选择协议,它融合了距离 矢量和链路状态两种路由选择协议的优点,使用闪速更新 算法,能最快的达到网络收敛(convergence) EIGRP特点如下 ...

  3. Linux route

    一.简介 Linux系统的route命令用于显示和操作IP路由表(show / manipulate the IP routing table).要实现两个不同的子网之间的通信,需要一台连接两个网络的 ...

  4. EIGRP特性 Stub Routing

    EIGRP stub routing这一特性首次出现在Cisco IOS Release 12.0(7)T中,后来在Release 12.0(15)S中被集成进去.这一特性增加了网络的稳定性,减少资源 ...

  5. 修改EIGRP 路径cost 值,以及分析和实现等价与非等价负载均衡

    一.拓扑图: 二.配置各路由器的IP和EIGRP 协议,并保证邻接关系的形成. 1.我要达到的目的是要让R2到192.168.14.0/24这个网段能在R2和R1断开之后,形成网网络的快速收敛.因为根 ...

  6. 配置和调试EIGRP

    [实验目的]: 在本次实验中,你将安装增强的内部网关路由协议(EIGRP)和观察它的缺省行为.然后优化EIGRP配置. 在完成本次实验之后,你需要完成下列任务: 核心和其他机架使用EIGRP路由协议 ...

  7. CCNA 之 六 路由协议 二 EIGRP

    EIGRP(Enhanced IGRP) 增强型内部网关路由协议 注意:这是cisco私有协议:也就是说,该协议只能运行在思科的设备上,如果有其他的厂家的设备,则不能保证能运行此协议: EIGRP的特 ...

  8. Linux命令之route - 显示和操作IP路由表

    转自:  http://codingstandards.iteye.com/blog/1125312 用途说明 route命令用于显示和操作IP路由表(show / manipulate the IP ...

  9. 关于Linux路由表的route命令(转)

    查看 Linux 内核路由表 使用下面的 route 命令可以查看 Linux 内核路由表. # route Destination  Gateway      Genmask          Fl ...

最新文章

  1. Codeforces Round #665 (Div. 2) 题解( 小学奥数专场 )
  2. 8张图让你一步步看清 async/await 和 promise 的执行顺序
  3. Oracle数据加载之sqlldr工具的介绍
  4. 获取多张表中的数据_趣说:什么是数据结构和算法
  5. mysql io 100_MySQL服务器 IO 100%的分析与优化方案
  6. 弹性服务器架构-连接一切的力量
  7. 在Ubuntu上编译libusb
  8. Docker(四) Dockerfile 详解
  9. 【报告分享】2021年营销数智化趋势洞察报告:深链经营孕育品牌发展新商机.pdf(附下载链接)...
  10. python复制文件到指定文件夹并重命名_python文件、文件夹的移动、复制、删除、重命名...
  11. 前端开发实习面经总结
  12. 干线公路交叉口右转车辆与非机动车冲突精细化治理实例
  13. pwnable.kr_mistake
  14. 运维工单系统 php,运维平台体系化建设之工单系统
  15. ant vue 的datepicker类组件中英文混合显示解决
  16. c语言实现cgi之cgic库使用
  17. 华为设备DHCP配置命令
  18. 免疫受体 AIRR 分析平台 immuneML 简介
  19. SOFT-SLAM系列论文解读
  20. ITON - 2 论名字

热门文章

  1. javamail发送html正文文件_Python实现-生成测试报告amp;自动邮件发送
  2. 排序系列之---冒泡排序
  3. 爬空气质量MySQL_爬虫:利用selenium采集某某环境网站的空气质量数据
  4. java软件工程_java复习
  5. defaultdict python3,Python collections.defaultdict() 与 dict的使用和区别|python3教程|python入门|python教程...
  6. memcached 使用 java_使用Java java_memcached client的陷阱
  7. python 变量类型list_Python基础变量类型——List浅析-阿里云开发者社区
  8. 电脑表格制作教程入门_第三节 CorelDRAW制作作品的流程 - CorelDRAW基础入门教程 - 平面设计学院...
  9. android广播注册源码,android 广播源码简要分析-注册
  10. java项目如何单元测试_大家java web项目开发做单元测试吗?