SVTI实验简单配置

R2 配置:

crypto isakmp policy 1
 encr 3des
 hash md5
 authentication pre-share
 group 2

################################

配置阶段1 policy 第 1 2个包交换的信息

################################
crypto isakmp key cisco123 address 200.1.1.4  // 配置预共享密钥   
!
!
crypto ipsec transform-set ccie esp-des esp-md5-hmac  
 mode tunnel

#################################

配置阶段2 transform  转换集

#################################
!
!
crypto ipsec profile ikeprof
 set transform-set ccie

!
!
interface Tunnel0
 ip address 1.1.1.1 255.255.255.0
 tunnel source 100.1.1.2
 tunnel destination 200.1.1.4
 tunnel protection ipsec profile ikeprof
!
interface Ethernet0/0
 ip address 10.1.1.2 255.255.255.0
!
interface Ethernet0/1
 ip address 100.1.1.2 255.255.255.0

!
router ospf 1
 network 1.1.1.0 0.0.0.255 area 0
 network 10.1.1.0 0.0.0.255 area 0

################################

将隧道口宣告ospf进程

################################
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 100.1.1.3

R2# show crypto session
Crypto session current status

Interface: Tunnel0
Session status: UP-ACTIVE    
Peer: 200.1.1.4 port 500
  Session ID: 0 
  IKEv1 SA: local 100.1.1.2/500 remote 200.1.1.4/500 Active
  Session ID: 0 
  IKEv1 SA: local 100.1.1.2/500 remote 200.1.1.4/500 Active
  IPSEC FLOW: permit 47 host 100.1.1.2 host 200.1.1.4
        Active SAs: 6, origin: crypto map

R2#show crypto engine connections active
Crypto Engine Connections

ID  Type    Algorithm           Encrypt  Decrypt LastSeqN IP-Address
    1  IPsec   DES+MD5                   0        1        1 100.1.1.2
    2  IPsec   DES+MD5                   0        0        0 100.1.1.2
    3  IPsec   DES+MD5                   0        0        0 100.1.1.2
    4  IPsec   DES+MD5                   0        0        0 100.1.1.2
    5  IPsec   DES+MD5                   0      203      203 100.1.1.2
    6  IPsec   DES+MD5                 204        0        0 100.1.1.2
 1001  IKE     MD5+3DES                  0        0        0 100.1.1.2
 1002  IKE     MD5+3DES                  0        0        0 100.1.1.2

R2#show crypto ipsec sa | include spi
     current outbound spi: 0x214BF7A1(558626721)
      spi: 0xB86713B9(3093763001)
      spi: 0xA66B2E85(2792042117)
      spi: 0x74849EDE(1954848478)
      spi: 0xC1C0AB59(3250629465)
      spi: 0xF0B7C9F6(4038576630)
      spi: 0x214BF7A1(558626721)
R2#show crypto ipsec sa

interface: Tunnel0
    Crypto map tag: Tunnel0-head-0, local addr 100.1.1.2

protected vrf: (none)
   local  ident (addr/mask/prot/port): (100.1.1.2/255.255.255.255/47/0)
   remote ident (addr/mask/prot/port): (200.1.1.4/255.255.255.255/47/0)
   current_peer 200.1.1.4 port 500
     PERMIT, flags={origin_is_acl,}
    #pkts encaps: 212, #pkts encrypt: 212, #pkts digest: 212
    #pkts decaps: 212, #pkts decrypt: 212, #pkts verify: 212
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts compr. failed: 0
    #pkts not decompressed: 0, #pkts decompress failed: 0
    #send errors 0, #recv errors 0

local crypto endpt.: 100.1.1.2, remote crypto endpt.: 200.1.1.4
     plaintext mtu 1446, path mtu 1500, ip mtu 1500, ip mtu idb Ethernet0/1
     current outbound spi: 0x214BF7A1(558626721)
     PFS (Y/N): N, DH group: none

inbound esp sas:
      spi: 0xB86713B9(3093763001)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 1, flow_id: SW:1, sibling_flags 80004040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4608000/1700)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)
      spi: 0xA66B2E85(2792042117)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 3, flow_id: SW:3, sibling_flags 80000040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4608000/1708)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)
      spi: 0x74849EDE(1954848478)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 5, flow_id: SW:5, sibling_flags 80000040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4284714/1708)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)

inbound ah sas:

inbound pcp sas:

outbound esp sas:
      spi: 0xC1C0AB59(3250629465)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 2, flow_id: SW:2, sibling_flags 80004040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4608000/1700)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)
      spi: 0xF0B7C9F6(4038576630)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 4, flow_id: SW:4, sibling_flags 80000040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4608000/1708)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)
      spi: 0x214BF7A1(558626721)
        transform: esp-des esp-md5-hmac ,
        in use settings ={Tunnel, }
        conn id: 6, flow_id: SW:6, sibling_flags 80000040, crypto map: Tunnel0-head-0
        sa timing: remaining key lifetime (k/sec): (4284714/1708)
        IV size: 8 bytes
        replay detection support: Y
        ecn bit support: Y status: off
        Status: ACTIVE(ACTIVE)

outbound ah sas:

outbound pcp sas:
R2#

转载于:https://blog.51cto.com/oppoa10000k/1769569

Cisco IPSec *** Gre over --- SVTI相关推荐

  1. Mac Cisco IPsec 添加路由表 分流

    居家办公用 Cisco IPsec 方式连公司VPN,由于VPN连接后会流量都会先从VPN经过,导致访问非公司网络极慢,搜索一番都得知可通过添加路由表让公司内网地址走VPN,非公司内网地址正常连接网络 ...

  2. cisco 2911 GRE ***

    实施GRE隧道技术 R1(config)#crypto isakmp policy 10 R1(config-isakmp)#encr 3des     hash  md5    authen pri ...

  3. Cisco IPSec *** 配置详解

    前言: ×××作为一项成熟的技术,广泛应用于组织总部和分支机构之间的组网互联,其利用组织已有的互联网出口,虚拟出一条"专线",将组织的分支机构和总部连接起来,组成一个大的局域网.I ...

  4. Cisco 配置 GRE隧道

    拓扑图 <!--思路:在R0和R1上做gre隧道--> R0配置 interface Tunnel 1 //配置GRE隧道模式ip address 172.16.1.1 255.255.2 ...

  5. 华为IPsce以及GRE over IPSec配置练习

    华为IPsce以及GRE over IPSec配置练习 一.拓扑以及需求 二.配置思路 (1)打通核心层 (2)利用GRE将PC1.PC2逻辑上连接起来 (3)需求加密1:加密PC3与PC4的通信数据 ...

  6. 《Cisco路由器配置与管理完全手册》(第二版)前言和目录

    史上最具人气.最受好评的网络设备图书领域"四大金刚"的全新升级版本再现江湖了,他们分别是:<Cisco交换机配置与管理完全手册>(第二版).<H3C交换机配置与管 ...

  7. IPSEC协议及当中IKE协商加解密原理

    散列函数:也叫Hash函数,主要是为保证数据完整性,主流算法有MD5.SHA-1. 散列值:通过散列函数计算得到的结果 对称密钥算法:使用相同的密钥与算法对数据进行加解密 运算 - 优点:速度快.安全 ...

  8. cisco在服务器编辑首页信息,cisco设置

    cisco路由向来以难配置而绝不天下.那么cisco怎么设置vlan ip?秋天网 Qiutian.ZqNF.Com小编整理了相关资料,给大家介绍.有需要学习的同学可参考参考. cisco设置vlan ...

  9. SANGFOR SCSA——虚拟专用网与IPSec解决方案

    虚拟专用网概述 IPSec解决方案 一.虚拟专用网络概述 企业,组织,商业等对专用网有强大的需求,高性能,高速度和高安全性是专用网明显的优势.但是物理上架设专用网价格不菲,架设实施难度大,以上两方面是 ...

最新文章

  1. 正则表达式了解和使用
  2. Eclipse 搭建struts2 spring3 hibernate3环境实战 待完善
  3. 使用VScode开发ESP32,PlatformIO开发ESP32
  4. linux 网络7层模型,Linux网络编程——OSI七层模型、TCP/IP模型
  5. 迁移学习---inceptionV3
  6. ubuntu18.10 cosmic更换阿里云的源
  7. java 多线程 优先级_java多线程之线程的优先级
  8. java中br.readline_Java:java中BufferedReader的read()及readLine()方法的使用心得
  9. linux 统计当前目录下文件或者文件夹的数量
  10. Button或者ImageButton的背景设为透明或者半透明
  11. html转pdf后修改,pdf转换器smallpdf转成HTML后怎么排版
  12. js 获取页面高度和宽度(兼容 ie firefox chrome),获取鼠标点击位置
  13. Macbook/Mac OS中阅读代码软件推荐
  14. Auto CAD 2020 2019 2018 2017 2016 2015 2014 2013 2012 2011 2010 全版本 附带安装教程+入门到精通视频教程
  15. 回归、自回归、循环神经网络(RNN)、LSTM
  16. 算法分析 | 分支限界算法设计之布线问题 C语言版
  17. 计算机excel操作知识点汇总,【计算机二级之Excel】考点汇总
  18. 揭密出席第九届中国云计算大会的专家—近20个国家学者共话云计算大数据生态、应用...
  19. python能制作ppt动画效果吗_那些超酷的视频效果,真的是用PPT动画做的吗?
  20. 钉钉小程序复选框 全选反选 表单获取内容有误处理

热门文章

  1. 关联数组不能转化为JSON字符串
  2. 201803-2碰撞的小球
  3. apt-get卸载命令
  4. iOS - 获取安装所有App的Bundle ID
  5. 转:【Java集合源码剖析】LinkedHashmap源码剖析
  6. Apache Derby-02通过IJ简单操作DERBY
  7. 【client】与【offset】
  8. 看几道JQuery试题后总结(下篇)
  9. 用bde连接 连接sql server2005
  10. CPU : Intel CPU命名规则