文章目录

  • 数据链路层封装技术
  • GRE
    • MGRE
  • 实验
    • 实验要求
    • 实验拓扑
    • 实验步骤
      • IP配置
      • HDLC封装(R1-R2)
      • ppp封装,pap认证(R2-R3)
      • ppp封装,chap认证(R2-R4)
      • MGRE环境
      • RIP宣告,NAT地址转换
      • 连通性测试

数据链路层封装技术

现在98%的网络都是基于以太网实现的,之所以串行链路没有被完全淘汰,是因为它更安全,以太网中的信息传输容易被第三者截获,而串行链路中只能点到点进行通信,就保证了数据的安全。
其中点到点即在一个网络中,节点的数量被物理和逻辑地限制为2个,他是基于点到点类型工作的二层封装技术,不存在二层单播地址,比如MAC地址
串行链路的二层技术:PPP、HDLC、FR、X25、ATM,我们这里只讲PPP、HDLC,其余的基本快淘汰,甚至已经淘汰。

  1. HDLC(High-Level Data Link Control,高级数据链路控制),是链路层协议的一项国际标准,每个厂商的HDLC技术均为私有技术,它是Cisco默认使用的封装技术

    将这个网络中的链路层协议修改为HDLC:
//R1
[R1]interface s4/0/0
[R1-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
Jul 18 2022 19:54:48-08:00 R1 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed the configuration that will change the encapsulation protocol of the link and then selected Y.
//R1
[R2]interface s4/0/0
[R2-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
Jul 18 2022 19:55:35-08:00 R2 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed the configuration that will change the encapsulation protocol of the link and then selected Y.

可以查看该接口来查看使用的协议:display interface s4/0/0

  1. ppp(Point-to-Point Protocol)点到点协议:它的网络类型是点到点网络类型,因此它没有二层地址,仅连接两个节点。
    他是非Cisco串线接口默认使用的封装技术(公有)

    在这种网络类型中,即便是不同网段的两点间也可以通信

PPP链路的建立有三个阶段的协商过程,链路层协商、认证协商(可选)和网络层协商
        链路层协商:通过LCP报文进行链路参数协商,建立链路层连接
        认证协商:通过链路建立阶段协商的认证方式进行链路认证(PAP、CHAP)
        网络层协商:通过NCP协商来选择和配置一个网络层协议并进行网络层参数协商

a. PAP(密码验证协议)是明文传递用户名和密码

//主认证方,R1
[R1]aaa
[R1-aaa]local-user huawei password cipher huawei123
Info: Add a new user.
[R1-aaa]local-user huawei service-type ppp
[R1-aaa]q
[R1]interface s4/0/0
[R1-Serial4/0/0]ppp authentication-mode pap
//被认证方,R2
[R2]interface s4/0/0
[R2-Serial4/0/0]ppp pap local-user huawei password cipher huawei123

但是修改后不会立即生效,需要重新启动shutdown+undo shutdown


被认证方发起认证,认证方返回ACK认证成功
b. CHAP(挑战握手认证协议),密文传输

//主认证方,R1(仅进口修改认证方式与PPP不一样)
[R1]aaa
[R1-aaa]local-user huawei password cipher huawei123
[R1-aaa]local-user huawei service-type ppp
[R1-aaa]q
[R1]interface s4/0/0
[R1-Serial4/0/0]ppp authentication-mode chap
//被认证方,R2
[R2]interface s4/0/0
[R2-Serial4/0/0]ppp chap user huawei
[R2-Serial4/0/0]ppp chap password cipher huawei123



CHAP认证双方有三次握手,协商报文被加密后再在链路上传输
又认证方先发起挑战,携带随机数,两方将随机数、ID值、密码进行哈希计算,得到MD5结果,比对成功则认证成功(整个过程没有传递密码)

GRE

下面来介绍一种VPN技术:GRE
VPN(Virtual Private Network):虚拟专用网络,让两个网络穿越中间网络来直接通讯,逻辑的在两个网络间建立了一条新的点到点直连链路,常用的VPN技术包括IPSec VPN、GRE VPN、L2TP VPN、MPLS VPN等。
GRE(General Routing Encapsulation,通用路由封装协议)是一种三层VPN封装协议,属于点到点网络类型。

它解决了异种网络的报文传输问题
乘客协议:用户在传输数据时所使用的原始网络协议
封装协议:用来“包装”乘客协议对应的报文,使得原始报文能够在新的网络中传输
运输协议:被封装以后的报文在新的网络中传输时所使用的网络协议

//先配好IP,且R1和R2写一条指向公网的缺省路由
//R1
[R1]interface LoopBack 0
[R1-LoopBack0]ip address 192.168.1.1 24
[R1-LoopBack0]q
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24
Jul 18 2022 21:14:56-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R1-GigabitEthernet0/0/0]q
[R1]ip route-static 0.0.0.0 0 12.1.1.2
//R2
[R2]interface LoopBack 1
[R2-LoopBack1]ip address 192.168.2.1 24
[R2-LoopBack1]q
[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address 23.1.1.2 24
Jul 18 2022 21:15:32-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R2-GigabitEthernet0/0/0]q
[R2]ip route-static 0.0.0.0 0 23.1.1.1
//R3(ISP)
[ISP]interface g0/0/0
[ISP-GigabitEthernet0/0/0]ip address 12.1.1.2 24
Jul 18 2022 21:15:46-08:00 ISP %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[ISP-GigabitEthernet0/0/0]q
[ISP]interface g0/0/1
[ISP-GigabitEthernet0/0/1]ip address 23.1.1.1 24
[ISP-GigabitEthernet0/0/1]
Jul 18 2022 21:15:57-08:00 ISP %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP on the interface GigabitEthernet0/0/1 has entered the UP state.
//创建R1与R2之间的隧道
//R1
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24  //给隧道写IP
[R1-Tunnel0/0/0]tunnel-protocol gre     //选择协议GRE
[R1-Tunnel0/0/0]source 12.1.1.1
[R1-Tunnel0/0/0]destination 23.1.1.2    //指定对端接口
Jul 18 2022 21:23:45-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
//R2
[R2]interface Tunnel 0/0/0
[R2-Tunnel0/0/0]ip ad
[R2-Tunnel0/0/0]ip address 10.1.1.2 24
[R2-Tunnel0/0/0]tun
[R2-Tunnel0/0/0]tunnel-protocol gre
[R2-Tunnel0/0/0]sou
[R2-Tunnel0/0/0]source 23.1.1.2
[R2-Tunnel0/0/0]dest
[R2-Tunnel0/0/0]destination 12.1.1.1
Jul 18 2022 21:25:43-08:00 R2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.

即使创建了隧道,依然不能通信,此时这两台路由器并没有对端内网路由,这时需要用到静态路由或动态路由

//静态路由
//R1
[R1]ip route-static 192.168.2.0 24 Tunnel 0/0/0
//R2
[R2]ip route-static 192.168.1.0 24 Tunnel 0/0/0

MGRE

MGRE即多点GRE
存在问题:在多个网络间需要通过VPN来建立形成一个整体的网络时,若使用点到点GRE,tunnel和网段的数量将成指数上升,路由表将变大,要求所有的节点为固定的公有IP地址;
普通的GRE为点到点网络类型,若将多个使用普通GRE的节点连接起来,将配置大量的网段和路由信息,且所有节点均为固定节点,此时MGRE使多个节点构成一个中心到站点的网络结构,站点可以基于NHRP实现IP地址不固定。
NHRP:下一条路由发现协议,非固定IP分支站点主动到固定IP的中心站点注册,中心站点生成MAP映射,即Tunnel口IP与公有IP地址的对应;若分支到分支,那么将在中心站点下载MAP来实现直接通信。

//先配好IP即缺省路由
//R1
[R1]interface LoopBack 0
[R1-LoopBack0]ip address 192.168.1.1 24
[R1-LoopBack0]q
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24
Jul 18 2022 21:52:36-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R1-GigabitEthernet0/0/0]q
[R1]ip route-static 0.0.0.0 0 12.1.1.2
//R2(ISP)
[ISP]interface g0/0/0
[ISP-GigabitEthernet0/0/0]ip address 12.1.1.2 24
Jul 18 2022 21:53:10-08:00 ISP %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[ISP-GigabitEthernet0/0/0]q
[ISP]interface g0/0/1
[ISP-GigabitEthernet0/0/1]ip address 23.1.1.2 24
Jul 18 2022 21:53:31-08:00 ISP %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP on the interface GigabitEthernet0/0/1 has entered the UP state.
[ISP-GigabitEthernet0/0/1]q
[ISP]interface g0/0/2
[ISP-GigabitEthernet0/0/2]ip address 34.1.1.2 24
Jul 18 2022 21:53:48-08:00 ISP %%01IFNET/4/LINK_STATE(l)[2]:The line protocol IP on the interface GigabitEthernet0/0/2 has entered the UP state.
//R3
[R3]interface LoopBack 1
[R3-LoopBack1]ip address 192.168.2.1 24
[R3-LoopBack1]q
[R3]interface  g0/0/0
[R3-GigabitEthernet0/0/0]ip address 23.1.1.3 24
Jul 18 2022 21:54:24-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R3-GigabitEthernet0/0/0]q
[R3]ip route-static 0.0.0.0 0 23.1.1.2
//R4
[R4]interface LoopBack 2
[R4-LoopBack2]ip address 192.168.3.1 24
[R4-LoopBack2]q
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 34.1.1.4 24
Jul 18 2022 21:55:21-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R4-GigabitEthernet0/0/0]q
[R4]ip route-static 0.0.0.0 0 34.1.1.2
//再搭建MGRE环境
//R1(中心站点)
[R1]interface Tunnel 0/0/0      //创建Tunnel口
[R1-Tunnel0/0/0]ip address 10.1.1.1 24      //配置IP地址
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp    //修改接口模式为多点GRE
[R1-Tunnel0/0/0]source 12.1.1.1         //定义公有的源IP地址
Jul 18 2022 22:00:07-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R1-Tunnel0/0/0]nhrp entry multicast dynamic    //本地成为NHRP中心,同时可以进行伪广播
[R1-Tunnel0/0/0]nhrp network-id 100         //默认为0号,该网段内所有节点Tunnel接口必为相同域
//R3
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.2 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source g0/0/0       //分支节点站点IP地址不固定
Jul 18 2022 22:06:58-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register   //NHRP协议,隧道IP+公有源IP
//R4
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.3 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp
[R4-Tunnel0/0/0]source g0/0/0
Jul 18 2022 22:11:07-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R4-Tunnel0/0/0]nhrp network-id 100
[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register

查看站点注册结果:display nhrp peer all

//最后一步使用RIP宣告,但是需要关闭水平分割机制
//R1
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0
[R1-rip-1]q
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]undo rip split-horizon  //关闭水平分割机制
//R3
[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 10.0.0.0
[R3-rip-1]network 192.168.2.0
//R4
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 10.0.0.0
[R4-rip-1]network 192.168.3.0

测试:(R3 -> R4)




实验

实验要求

  1. R2为ISP,其上只能配置IP地址
  2. R1-R2之间为HDLC封装
  3. R2-R3之间为ppp封装,pap认证,R2为主认证方
  4. R2-R4之间为ppp封装,chap认证,R2为主认证方
  5. R1、R3、R4构建MGRE环境,仅R1 IP地址固定
  6. 内网使用RIP协议获取路由,所有PC可以互相访问,并且可以访问R2的环回

实验拓扑

实验步骤

IP配置

R1

<Huawei>system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R1
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
Jul 18 2022 15:37:17-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R1-GigabitEthernet0/0/0]q
[R1]interface s4/0/0
[R1-Serial4/0/0]ip address 12.1.1.1 24
[R1-Serial4/0/0]q
[R1]

R2(ISP)

<Huawei>system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname ISP
[ISP]interface s4/0/0
[ISP-Serial4/0/0]ip address 12.1.1.2 24
[ISP-Serial4/0/0]
Jul 18 2022 15:38:56-08:00 ISP %%01IFNET/4/LINK_STATE(l)[0]:The line protocol PPP IPCP on the interface Serial4/0/0 has entered the UP state.
[ISP-Serial4/0/0]q
[ISP]interface s4/0/1
[ISP-Serial4/0/1]ip address 23.1.1.2 24
[ISP-Serial4/0/1]q
[ISP]interface s3/0/0
[ISP-Serial3/0/0]ip address 34.1.1.2 24
[ISP-Serial3/0/0]q
[ISP]interface LoopBack 0
[ISP-LoopBack0]ip address 2.2.2.2 24
[ISP-LoopBack0]q
[ISP]

R3

<Huawei>system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R3
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.2.1 24
Jul 18 2022 15:41:34-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R3-GigabitEthernet0/0/0]q
[R3]interface s4/0/0
[R3-Serial4/0/0]ip address 23.1.1.3 24
[R3-Serial4/0/0]
Jul 18 2022 15:41:50-08:00 R3 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol PPP IPCP on the interface Serial4/0/0 has entered the UP state.
[R3-Serial4/0/0]q
[R3]

R4

<Huawei>system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R4
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[R4-GigabitEthernet0/0/0]q
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 34.1.1.4 24
Jul 18 2022 15:42:57-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface GigabitEthernet0/0/0 has entered the UP state.
[R4-GigabitEthernet0/0/0]q
[R4]

HDLC封装(R1-R2)

//R1
[R1]interface s4/0/0
[R1-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
Jul 18 2022 15:46:38-08:00 R1 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed the configuration that will change the encapsulation protocol of the link and then selected Y.
//R2(ISP)
[ISP]interface s4/0/0
[ISP-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
Jul 18 2022 15:47:08-08:00 ISP %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed the configuration that will change the encapsulation protocol of the link and then selected Y.

ppp封装,pap认证(R2-R3)

//R2(ISP),主认证方
[ISP]aaa
[ISP-aaa]local-user huawei password cipher huawei123
Info: Add a new user.
[ISP-aaa]local-user huawei service-type ppp
[ISP-aaa]q
[ISP]interface s4/0/1
[ISP-Serial4/0/1]link-protocol ppp
[ISP-Serial4/0/1]ppp authentication-mode pap
//R3,被认证方
[R3]interface s4/0/0
[R3-Serial4/0/0]link-protocol ppp
[R3-Serial4/0/0]ppp pap local-user huawei password cipher huawei123

ppp封装,chap认证(R2-R4)

//R2(ISP),主认证方
[ISP]aaa
[ISP-aaa]local-user huawei password cipher huawei123
[ISP-aaa]local-user huawei service-type ppp
[ISP-aaa]q
[ISP]interface s3/0/0
[ISP-Serial3/0/0]link-protocol ppp
[ISP-Serial3/0/0]ppp authentication-mode chap
//R4,被认证方
[R4]interface s4/0/0
[R4-Serial4/0/0]link-protocol ppp
[R4-Serial4/0/0]ppp chap user huawei
[R4-Serial4/0/0]ppp chap password cipher huawei123

MGRE环境

R1、R3、R4向ISP写缺省路由

//R1
[R1]ip route-static 0.0.0.0 0 12.1.1.2
//R3
[R3]ip route-static 0.0.0.0 0 23.1.1.2
//R4
[R4]ip route-static 0.0.0.0 0 34.1.1.2
//R1,中心站点
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 12.1.1.1
Jul 18 2022 16:05:57-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
[R1-Tunnel0/0/0]nhrp network-id 100
//R3
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source s4/0/0
Jul 18 2022 16:21:31-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register
//R4
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.4 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp
[R4-Tunnel0/0/0]source s4/0/0
Jul 18 2022 18:06:19-08:00 R4 %%01IFNET/4/LINK_STATE(l)[3]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[R4-Tunnel0/0/0]nhrp network-id 100
[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register

RIP宣告,NAT地址转换

RIP宣告

//R1
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0
[R1-rip-1]q
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]undo rip split-horizon
//R3
[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 192.168.2.0
[R3-rip-1]network 10.0.0.0
//R4
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 192.168.3.0
[R4-rip-1]network 10.0.0.0

NAT 地址转换

//R1
[R1]acl 2000
[R1-acl-basic-2000]rule 1 permit source any
[R1-acl-basic-2000]q
[R1]interface s4/0/0
[R1-Serial4/0/0]nat outbound 2000
//R3
[R3]acl 2000
[R3-acl-basic-2000]rule 1 permit source any
[R3-acl-basic-2000]q
[R3]interface s4/0/0
[R3-Serial4/0/0]nat outbound 2000
//R4
[R4]acl 2000
[R4-acl-basic-2000]rule 1 permit source any
[R4-acl-basic-2000]q
[R4]interface s4/0/0
[R4-Serial4/0/0]nat outbound 2000

连通性测试

PC2 -> PC3

【HCIP】数据链路层封装技术、GRE及实验(eNSP)相关推荐

  1. HCIP版———二层技术——点对点协议ppp以及NBMA网络MGRE的tunnel隧道技术以及二层综合实验

    一.网络类型: 点到点 BMA:广播型多路访问 – 在一个MA网络中同时存在广播(洪泛)机制 NBMA:非广播型多路访问-在一个MA网络中,没有洪泛机制 MA:多路访问 在一个网段内,存在的节点数量不 ...

  2. 通用路由封装协议--GRE的简单配置

    基于华为设备简单配置GRE GRE--通用路由封装协议 一.GRE是什么? 二.GRE有什么用? 1.多协议本地网可以通过GRE隧道传输 2.与IPSec结合,保护组播数据 三.GRE怎么用? 1.隧 ...

  3. 广域网技术(二层封装技术)

    广域网技术(二层封装技术) (LAN:局域网   WAN:广域网   WLAN:无线局域网   VLAN:虚拟局域网)(最早带宽:两根铜丝64kbit/s) 1.二层 - 数据链路层 (1)分类:不同 ...

  4. 网络协议学习:通用路由封装协议GRE

    隧道技术 Tunneling 网络隧道技术(Tunneling)指的是利用一种网络协议来传输另一种网络协议,它主要利用网络隧道协议来实现这种功能. 简单来说,使用隧道技术可以理解为,在一些网络链路中使 ...

  5. 技术人文|声音捐赠,一场PBL式技术预研实验

    你有没有想过,在不能说话的情况下该如何向不识字的摊主点不加香菜的二两毛细(拉面)? "用手比划?"  "画在纸上?"  "找别人帮忙?" 这 ...

  6. 南邮微型计算机实验,南邮 微机原理 微型计算机与接口技术 微机原理实验.doc...

    南邮 微机原理 微型计算机与接口技术 微机原理实验.doc (3页) 本资源提供全文预览,点击全文预览即可全文预览,如果喜欢文档就下载吧,查找使用更方便哦! 9.90 积分  ;FILEMENT:E ...

  7. cpu封装技术 cpu知识 zol术语

    cpu封装技术 所谓"cpu封装技术"是一种将集成电路用绝缘的塑料或陶瓷材料打包的技术.以cpu为例,我们实际看到的体积和外观并不是真正的cpu内核的大小和面貌,而是cpu内核等元 ...

  8. 计算机微机原理及接口技术实训室,《微机原理与接口技术》课程实验报告.doc...

    <微机原理与接口技术>课程实验报告 实验一基本操作 一.实验目的 ? 1.熟悉Netlab MCS-51单片机实验系统的设置和使用方法 2.掌握基本MCS-51软件的编写.修改和编译的方法 ...

  9. IOS开发沙盒路径的封装技术

    IOS开发沙盒路径的封装技术 实现对NSString 类的分类 导入头文件,即可获取沙盒路径 //沙盒 使用分类的思想 File 填 Sandbox File Type 填 Calegory 分类 C ...

最新文章

  1. Spring Boot第四篇:SpringBoot 整合JPA
  2. Liteide go: cannot find GOROOT directory
  3. 第四范式AI新品发布会报名开启(8月20日·上海)
  4. Django 模板语言 标签
  5. [转] Vb中FSO 对象的介绍
  6. 16位顶尖对冲基金大佬:畅谈量化投资的下个10年!
  7. Protel DXP 2004 SP3_SP4 注册机
  8. 人大金仓数据库使用uuid
  9. win7计算机怎么初始化,win7怎么初始化电脑 win7初始化电脑步骤
  10. 8.局部变量、成员变量、jvm垃圾回收机制 、封装、this关键字、匿名对象
  11. 日常运维-端口查询篇
  12. 智能问答技术概览及在小爱同学的实践
  13. Postman变量的使用
  14. Java-基于SSM的健身后台管理系统
  15. matlab绘图 作业,实验作业2 - -MATLAB作图
  16. wordpress目录不分层级方法!去掉WordPress目录链接中category?目录在根目录
  17. 理解机器学习中的偏差与方差
  18. 【动态】雷电网络预览:以太坊扩容解决方案发布开发者演示
  19. Python中getopt()函数的使用
  20. OceanBase分区

热门文章

  1. 今天的码农女孩做了关于文件操作和文件拖拽的笔记 2022/1/21
  2. 堪称精华的Desktop TD介绍文章
  3. DataGrip 导出数据 Groovy 脚本 MacOS
  4. OpenBionics外骨骼项目介绍|BCIduino社区整理
  5. 单点登录(sso)的实现思路
  6. ASP。NET MVC警告横幅使用Bootstrap和AngularUI Bootstrap
  7. 2021-05-07-今日活动方案分享
  8. 用关键词获取商品订单列表详情
  9. matlab tlc,编写封装程序 S-Function 和 TLC 文件
  10. 抗倾覆机器人_抗倾覆稳定性,toppling stability,音标,读音,翻译,英文例句,英语词典...