先说点题外话,本来这两天是没时间来更新博客了的,但是事情出了点变化,使得我又有时间上网了,上网当然要到博客里面去逛逛了,没想到收到一封来自51cto的短信,说我的博客已经被评为推荐博客了,呵呵,真的很高兴能得到这样的荣誉,51cto让我感受到了学习的乐趣和写博客的动力(之前在csdn很没动力),更重要的是,能和这么多的网络技术爱好者共同学习,实在是一件很美妙的事情。感谢51cto。

最近我的这几篇关于cisco基础实验的文章都有幸得到了推荐,从网友的回复看,大多数网友还是支持我的,虽然我的文章对一部分博友来说很初级,但他们都没有说,相反还得到了他们的多次指点,真的很谢谢他们。当然我相信,我不会永远做初级的实验的,我是按照进度来循序渐进的进行的,总会做到高级一点的实验的,呵呵,当然,今天的实验应该还算初级的,呵呵。下面看实验。
实验开始前先说说Loopback接口,它是应用最为广泛的一种虚接口(即是接口不会依赖物理接口,接口的状态永远是UP的),网管完成网络规划之后,为了方便管理,会为每一台路由器创建一个loopback 接口,并在该接口上单独指定一个IP 地址作为管理地址,管理员会使用该地址对路由器远程登录(telnet)。因此学习它的配置还是有一定的意义的。
拓扑图如上所示,今天的实验通过show  的方式来展现,一来比较简短,二来比较易于察看,一目了然。
 1.1 在r1上show run:
r1#show run
Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface Loopback
 ip address 10.1.1.1 255.255.255.0
 no ip directed broadcast
!
interface Serial0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 clock rate 64000
!
interface Ethernet0
 ip address 192.168.1.2 255.255.255.0
 no ip directed-broadcast
!
!
router rip
 network 192.168.1.0
 network 192.168.2.0
 network 10.0.0.0     //我的loopback接口的IP地址为10.1.1.1
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4                         /启用了vty线路方可进行telnet
 login
 password cisco
!
no scheduler allocate
end
                     1.2在r1上show ip route

r1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route
Gateway of last resort is not set
     192.168.1.0/24 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Ethernet0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback
     192.168.2.0/24 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Serial0
     192.168.3.0/24 is subnetted, 1 subnets
R       192.168.3.0 [120/1] via 192.168.2.2, 00:01:25, Serial0         //这个英文比较简单,应该看得懂
1.3 在r1上show ip  pro
r1#show ip pro
Routing Protocol is "rip" 
  Sending updates every 30 seconds, next due in 7 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240     //从这句可以得知:该配置采用rip协议,路由器每隔30s发出更新信息,(next due in 7 seconds?),超过180s未收到路由更新则认为该路由无效,如果经过240s还没收到更新信息,这该路由信息将会从路由表中删除。
  Outgoing update filter list for all interfaces is
  Incoming update filter list for all interfaces is
  Redistributing:   rip
  Default version control: send version 1, receive any version
    Interface        Send  Recv   Key-chain
    Serial0            1    1 2
    Ethernet0          1    1 2
  Routing for Networks:
    192.168.1.0
    192.168.2.0
    10.0.0.0
  Routing Information Sources:
    192.168.2.2           120      00:00:09
  Distance: (default is 120)       //rip的管理距离默认为120,该值越小越好
21.在r2上show run:
r2#show run
Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
 no ip directed-broadcast
!
!
router rip
 network 192.168.3.0
 network 192.168.2.0
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
2.2在r2上show ip route
r2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route
Gateway of last resort is not set
     192.168.2.0/24 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Serial0
     192.168.3.0/24 is subnetted, 1 subnets
C       192.168.3.0 is directly connected, Ethernet0
     192.168.1.0/24 is subnetted, 1 subnets
R       192.168.1.0 [120/1] via 192.168.2.1, 00:08:16, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
R       10.1.1.0 [120/1] via 192.168.2.1, 00:02:14, Serial0
2.3 在r2上show ip pro
r2#show ip pro
Routing Protocol is "rip" 
  Sending updates every 30 seconds, next due in 4 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is
  Incoming update filter list for all interfaces is
  Redistributing:   rip
  Default version control: send version 1, receive any version
    Interface        Send  Recv   Key-chain
    Serial0            1    1 2
    Ethernet0          1    1 2
  Routing for Networks:
    192.168.3.0
    192.168.2.0
  Routing Information Sources:
    192.168.2.1           120      00:00:03
  Distance: (default is 120)  //意思同r1中的意思
                             3.pc1的配置
ipconfig /ip 192.168.1.1 255.255.255.0
ipconfig /dg 192.168.1.2
                              4.pc2的配置
ipconfig /ip 192.168.3.2 255.255.255.0
ipconfig /dg 192.168.3.1
                              5.远程登录验证
 

 如图所示,在输入telnet 10.1.1.1 并回车之后,会要求输入密码,此处为cisco,输入之后便可以在pc1上对r1进行配置。
        以前做实验,做完之后就只想到让它们互相ping通就好了,但是自从经过博友的提醒之后,才发现原来做实验并不仅仅局限于此,实验做完之后还可以学到很多的东西,再次谢谢众博友。 


本文转自 victoryan 51CTO博客,原文链接:http://blog.51cto.com/victoryan/39231

cisco路由器基本实验之五 配置Loopback接口进行远程登录 (Boson NetSim)相关推荐

  1. cisco路由器 三层交换机简单环境配置实例(图)

    出处:http://www.jb51.NET/softjc/56600.html cisco路由器&三层交换机简单环境配置实例 一.网络拓扑图: 二.配置命令: 1.路由器的配置: inter ...

  2. 华为路由器/交换机配置telnet,ssh远程登录

    华为路由器/交换机配置telnet,ssh远程登录 文章目录 华为路由器/交换机配置telnet,ssh远程登录 1. Telnet 1.1 新建账号 1.2 配置远程访问 1.3 客户端远程访问 1 ...

  3. 华为S5700交换机初始化和配置SSH和TELNET远程登录方法

    华为S5700交换机初始化和配置TELNET远程登录方法: 1,交换机开启Telnet服务 <Huawei>system-view       #进入系统视图 [Huawei]telnet ...

  4. Ubuntu下VScode配置ssh免密远程登录

    一 实现步骤 1.在本机与远程服务器上, 输入ssh-keygen -t rsa,然后连续回车直到结束 2.在本机上执行命令 ssh-copy-id 命令 (1).命令介绍 ssh-copy-id命令 ...

  5. 锐捷交换机配置Telnet、ssh远程登录

    远程登录Telnet Ruijie(config)# line vty first-line [last-line] 进入 Line配置模式,VTY是远程登录 Ruijie(config-line)# ...

  6. cisco路由器基本实验之一 静态路由的配置(Boson NetSim

    花了快一个月的时间之后,我的Linux服务器建设学习算是小告了一个段落了.现在开始要回到windows里面利用Boson NetSim这个cisco实验模拟器来加深对路由交换的配置学习了.好在上学期上 ...

  7. cisco路由器基本实验之四 动态路由之IGRP协议的配置(Boson NetSim)

    又快到了开学的时间了,所以最近要整理一些开学用的东西,可能要忙一点了,但是cisco系列的基本实验还是得完成,把它们写在博客上也可以作为自己学习路上的的见证,哈哈,闲话不说,还是看实验.今天是配置IG ...

  8. cisco路由器基本实验之一 静态路由的配置(Boson NetSim)

    花了快一个月的时间之后,我的Linux服务器建设学习算是小告了一个段落了.现在开始要回到windows里面利用Boson NetSim这个cisco实验模拟器来加深对路由交换的配置学习了.好在上学期上 ...

  9. cisco路由器基本实验之三 动态路由之RIP协议的配置(Boson NetSim)

    言归正传,Boson Netsim的实验规划,默认路由下一个实验应该是RIP协议的配置.众所周知,RIP(Routing Information Protocol),即路由信息协议,它与IGRP,OS ...

最新文章

  1. poj3422(最小费用流 + 拆点)
  2. 写了一个好玩的小软件, 监视鼠标以及键盘的动作, 全局钩子. HowTired
  3. 将assembly包添加到自己的maven仓库
  4. 第十七讲 利用傅里叶级数求特解
  5. 【中级软考】两个人同一日就同样的发明创造申请专利,应该授予谁?
  6. 网上图书商城项目学习笔记-035工具类之JdbcUtils及TxQueryRunner及C3P0配置
  7. iOS之深度剖析UIScrollView的实现原理与阻尼动画
  8. Volley框架使用及源码解析
  9. CSS 技巧tips1
  10. Microsoft将在UWP上支持React Native,同时为VS Code添加工具软件
  11. 每日干货丨C语言知识总结----循环结构
  12. odbc远程连接mysql_无法使用unixodbc,libmyodbc连接到远程mysql服务器
  13. 看完这篇操作系统,和面试官扯皮就没问题了!
  14. magento 高级搜索 brand实例 Magento ‘Shop By Brand’ in SideBar
  15. 房租抵扣个税不用再填房东信息 房东这下放心了吗?
  16. 中国各省份中英文,Json格式
  17. c语言rc,RC低通滤波器中R和C参数选择
  18. 微信公众号文章如何设置关键词自动回复链接
  19. 酒店短视频营销,是酒店获客引流的重点推广手段之一
  20. Illegal instruction 问题处理

热门文章

  1. ios wifi 定位_iOS中三种定位方式
  2. ffmpeg安装教程(windows版)
  3. Android 9 红米4x,红米4X lineage16 安卓9.0 极致省电 纯净 完美root Xposed 经典版
  4. python打印实心菱形图案_python输入三角形三边求面积|python打印实心菱形图案
  5. Typora+smms+picGo(app) 图床使用办法
  6. typora 配置 smms 图床
  7. 使用Core Graphics绘画一个山寨微信icon
  8. R语言中的Wilcoxon符号秩检验与配对学生t检验
  9. 大调小调是什么意思?
  10. 为技术发声,因分享发光——最受开发者欢迎的“开发者布道师”评选结果来啦!...