交换机VLANTRUNKVTP 配置

1. 配置 CISCO 二层交换机的IP 地址(catalyst 2950 为例)

SW1(config)#int vlan 1 //进入管理接口interface vlan 1

SW1(config-if)#ip address 11.1.1.2 255.255.255.0 //配置IP 地址

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#ip default-gateway 11.1.1.1 //配置网关,可通过show run 查

查看所配置的 IP 地址:

SW1#show int vlan 1

Vlan1 is up, line protocol is up

Hardware is CPU Interface, address is 0008.20ff.6400 (bia 0008.20ff.6400)

Internet address is 11.1.1.2/24

2.配置交换机的端口速度和双工(Speed and Duplex)

SW1(config)#interface fa0/1

SW1(config-if)#speed {10 | 100 | auto} //10M/100M/自适应

SW1(config-if)#duplex {auto | full | half} //自适应/全双工/半双工

一般情况下,交换机两端的端口速度和双工要匹配,这样通信质量才能得到保证,在相同厂家的产品

(比如说Cisco 的交换机互连)中端口协商不用配置一般不会有什么问题,可以通过show interface 查

看端口的速度和双工。通常在不同厂家的产品中(比如说Cisco 和华为互连)如果通过查看发现端口速

度和双工不匹配,可以通过手工配置来解决。如图:

通过 show interface 查看端口的速度和双工:

SW1#show interfaces fastEthernet 0/24

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0008.20ff.6418 (bia 0008.20ff.6418)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:03, output 00:00:00, output hang never

注:CISCO 交换机端口默认值:Auto-duplex, Auto-speed, media type is 100BaseTX

Cisco 设备配置端口速度(speed)和双工(duplex)命令:

SW1(config)#interface fastEthernet 0/24

SW1(config-if)#speed ?

10 Force 10 Mbps operation ----------------------------注:强制速度为10M

100 Force 100 Mbps operation---------------------------注:强制速度为100M

auto Enable AUTO speed configuration -----------------注:速度自动协议(默认值)

SW1(config-if)#duplex ?

auto Enable AUTO duplex configuration ----------------注:自动协商双工

full Force full duplex operation ---------------------------注:强制为全双工

half Force half-duplex operation --------------------------注:强制为半双工

3.设置永久MAC 地址不过期

SW1(config)#mac-address-table static mac_addr {vlan vlan_id} [interface int1 [int2 ... int15]]

SW1(config)#mac-address-table static 1111.1111.a111 vlan 1 interface f0/1

配置后show mac-address-table 可以看到静态添加的MAC 地址1111.1111.a111

SW1#show mac-address-table

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 000f.72db.4ec0 STATIC CPU

1 1111.1111.a111 STATIC Fa0/1

4.管理MAC 地址表

SW1#show mac-address-table

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 000f.72db.4ec0 STATIC CPU

1 0000.0c3f.0b05 DYNAMIC Fa0/12

1 0030.94e6.391d DYNAMIC Fa0/11

1 00e0.b05a.5bfe DYNAMIC Fa0/10

1 1111.1111.a111 STATIC Fa0/1

5.设置交换机端口的访问模式(三种) access /dynamic / trunk

SW1(config-if)#switchport mode ?

access Set trunking mode to ACCESS unconditionally

dynamic Set trunking mode to dynamically negotiate access or trunk mode

trunk Set trunking mode to TRUNK unconditionally

SW1(config)#int fastEthernet 0/1

SW1(config-if)#switchport mode access //设置FA0/1 为ACCESS 模式

SW1(config-if)#switchport mode trunk //设置FA0/1 为TRUNK 模式

SW1(config-if)#switchport mode dynamic auto //设置FA0/1 为自动直协商模式(默认)

交换机TRUNK 端口配置:

1)一般交换机与交换机相连接的端口要设置为trunk 模式

2 )如果是梳心交换机与非网管的交换机相连,梳心交换机端口设置为access 模式

如下图:

配置 SW1:

SW1(config)#int f0/24

SW1(config-if)#no shutdown

SW1(config-if)#switchport mode trunk //设置FA0/24 为TRUNK 模式

配置 SW2:

SW2(config)#int f0/24

SW2(config-if)#no shutdown

SW2(config-if)#switchport mode trunk //设置FA0/24 为TRUNK 模式

验证 TRUNK 命令:

Show interface trunk

Show interface f0/24 switchport

SW1#sho run int f0/24

interface FastEthernet0/24

switchport mode trunk

SW1#show int trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

SW1#show int f0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

SW1#

SW2:

SW2#sho run int f0/24

interface FastEthernet0/24

switchport mode trunk

end

SW2#show int trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

6.配置VLAN

1).创建VLAN

SW1(config)#vlan 2 //创建VLAN2

SW1(config)#name VLAN2 //命名为VLAN2,默认为vlan002,命名是可选命令

2).将端口加入VLAN

SW1(config-if)#switchport mode access //设配端口为access 模式

SW1(config-if)#switchport access vlan 2 //把端口加到vlan2

3).检查的命令

Switch#show vlan

例子:

创建 VLAN2 命令为widom ,

创建VLAN3 命令为market

把端口F0/4 加入VLAN2

SW1#config t

SW1(config)#vlan 2

SW1(config-vlan)#name wisdom

SW1(config-vlan)#exit

SW1(config)#vlan 3

SW1(config-vlan)#name market

SW1(config-vlan)#exit

SW1(config)#int fas0/4

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 2

可以同时把多个端口加入到相应VLAN

SW1(config)#interface range fastEthernet 0/10 – 15 //可以同时把多个端口加入到一个VLAN 里

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 3 //把端口10-15 都加入到VLAN3 里

SW1#show vlan //检查VLAN 信息

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/5, Fa0/6, Fa0/7

Fa0/8, Fa0/9, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 wisdom active Fa0/4

3 market active Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15

SW1#

7.配置VTP----VTP 技术使得在大型的网络里布置多个VLAN 变得简单.

VTP 的配置步骤:

1、配置Trunk (交换机和交换机相连的端口要设置为TRUNK)

2、配置VTP DOMAIN

3、配置VTP MODE

4、配置VLAN

5、将端口加入VLAN

6、检查

Switch#show interface xx/xx switchport //查看相应该接口的trunk 状态

Switch#show vtp status  //查看vtp 状态

Switch#show vlan //查看VLAN

配置 SW1:

SW1#configure terminal

SW1(config)#interface fastEthernet 0/24

SW1(config-if)#switchport mode trunk

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#vtp domain wisdom

Domain name already set to wisdom.

SW1(config)#vtp mode server

Device mode already VTP SERVER.

SW1(config)#vtp password cisco

Setting device VLAN database password to cisco

SW1(config)#vtp pruning //配置VTP 的修剪,只要在SERVER 端配置就行.

Pruning switched on

SW1#sho vtp status

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 64

Number of existing VLANs : 5

VTP Operating Mode : Server

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xE8 0x5A 0x7D 0xB1 0x0E 0xBC 0xEB 0x1F

Configuration last modified by 11.1.1.2 at 3-1-93 02:56:31

Local updater ID is 11.1.1.2 on interface Vl1 (lowest numbered VLAN interface found)

创建 VLAN2 VLAN3 VLAN4 VLAN5

SW1(config)#vlan 2

SW1(config-vlan)#vlan 3

SW1(config-vlan)#vlan 4

SW1(config-vlan)#vlan 5

SW1(config-vlan)#

在 SW1 上创建VLAN 后查看修订版本:

SW1#show vtp status

VTP Version : 2

Configuration Revision : 5

Maximum VLANs supported locally : 128

Number of existing VLANs : 9

VTP Operating Mode : Server

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x9C 0x64 0xD6 0x44 0x5E 0x54 0x9E 0xFC

Configuration last modified by 11.1.1.2 at 3-1-93 02:59:04

Local updater ID is 11.1.1.2 on interface Vl1 (lowest numbered VLAN interface found)

在交换机 SW1 上检查已创建的VLAN

SW1#sho vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/5, Fa0/6, Fa0/7

Fa0/8, Fa0/9, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 VLAN0002 active

3 VLAN0003 active

4 VLAN0004 active

5 VLAN0005 active

检查 trunk 端口:

SW1#show interfaces fastEthernet 0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

配置 SW2:

Switch#

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#hostname SW2

SW2(config)#int fastEthernet 0/24

SW2(config-if)#switchport mode trunk

SW2(config-if)#exit

SW2(config)#vtp domain wisdom

Changing VTP domain name from test to wisdom

SW2(config)#vtp mode client

Setting device to VTP CLIENT mode.

SW2(config)#vtp password cisco

Setting device VLAN database password to cisco

SW2(config)#

查看 F0/24trunk 状态:

SW2#show interfaces fastEthernet 0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

查看 VTP 状态:

SW2#show vtp status

VTP Version : 2

Configuration Revision : 5

Maximum VLANs supported locally : 128

Number of existing VLANs : 9

VTP Operating Mode : Client

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x9C 0x64 0xD6 0x44 0x5E 0x54 0x9E 0xFC

Configuration last modified by 11.1.1.2 at 3-1-93 02:59:04

----------此处可以看到SW2 的VLAN 信息是从SW1-11.1.1.2 同步过来的

SW2#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5

Fa0/6, Fa0/7, Fa0/8, Fa0/9

Fa0/10, Fa0/11, Fa0/12, Fa0/13

Fa0/14, Fa0/15, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 VLAN0002 active

3 VLAN0003 active

4 VLAN0004 active

5 VLAN0005 active

实验结果:

SW2 不用配置VLAN,已同步了SW1 的VLAN 信息.实验成功

SW2 同步VTP SERVER 的VLAN 后,接下来的操作就是安要求把相应的端口加入到相应的VLAN

转载于:https://www.cnblogs.com/fatt/p/4353736.html

交换机VLAN、 TRUNK 、VTP 配置相关推荐

  1. 交换机接口trunk的配置和vlan的划分

    交换机接口trunk的配置和vlan的划分 试验目的:了解交换机接口的trunk的配置和vlan的划分 试验环境:如下图所示的拓扑图 我们要实现pc1和pc3在一个vlan2上,pc2和pc4在一个v ...

  2. 对VLAN,TRUNK,VTP和CHANNEL实验总结

    对VLAN,TRUNK,VTP和CHANNEL实验总结 VLAN 虚拟局域网VLAN(Virtual LAN)是交换机端口的逻辑组合.VLAN 工作在OSI的第2 层,一个VLAN 就是一个广播域,V ...

  3. 华为交换机VLAN Trunk模式设置

    通过console线连接交换机. 使用MobaXterm连接交换机. 输入system-view命令切换到管理模式. 设置端口1为trunk模式 interface GigabitEthernet 0 ...

  4. 利用VTP协议实现交换机 VLAN配置的一致性

    利用VTP协议实现交换机 VLAN配置的一致性 试验地点:东郊校区二楼第三机房 试验设备:Catalyst 2950 三台(SW3.SW5.SW6) 试验目标:1.利用VTP协议实现交换机VLAN统一 ...

  5. IBM bladecenter H刀箱BladeCenter北电交换机VLAN配置

    原创作者:运维工程师 谢晋 配置刀箱交换机 前提 环境说明 配置方法 交换机配置 配置新VLAN 配置端口 配置TRUNK组 前提 环境说明 客户有台刀箱交换机原先端口全放通,现需要对Vlan进行限制 ...

  6. 《CCIE路由和交换认证考试指南(第5版) (第1卷)》——2.4节VLAN Trunk协议

    本节书摘来自异步社区<CCIE路由和交换认证考试指南(第5版) (第1卷)>一书中的第2章,第2.4节VLAN Trunk协议,作者 [美]Narbik Kocharians(那比克 科查 ...

  7. 计算机网络实验-交换机VLAN实验

    一.实验目的 (1)理解二层交换机的缺陷. (2)理解交换机的VLAN,掌握其应用场合. (3)掌握二层交换机VLAN的基础配置. 二.实验仪器 1.装有Cisco Packet Tracer的Win ...

  8. 华为交换机vlan与trunk配置

    首先,使用ensp软件搭建好实验环境,并提取途中重要信息. 图中PC19和PC21在同一个vlan5,PC20和PC22在同一个vlan10 解题思路 (1) 首先我们需要确定我们需要用到的端口模式: ...

  9. 交换机与路由器技术:VLAN Trunk、单臂路由和三层交换及配置

    目录 一.VLAN Trunk 1.vlan trunk目的 2.trunk封装 二.单臂路由 1.原理 三.三层交换 1.目的 2.基本概念 3.传统的三层交换 4.基于CEF的三层交换(MLS) ...

最新文章

  1. 记录一次OOM分析过程
  2. PowerDesigner基本使用
  3. 动态载入树 (ASP+数据库)
  4. 中缀表达式转换为前缀及后缀表达式并求值【摘】
  5. 计算机 360云盘删除,xp系统下如何删除360云盘显示图标
  6. php中如何滚动文字,HTML_网页HTML代码:滚动文字的制作,制作滚动文字 通过本章前面 - phpStudy...
  7. [Link]选择一个 Python Web 框架:Django vs Flask vs Pyramid
  8. java 图片操作_Java对图片的操作
  9. NLP学习—12.Seq2Seq模型与Attention机制
  10. STM32F407引脚资源总结
  11. PPT宏编程——ChineseCounter
  12. 利用EasyPub为Kindle制作mobi格式书籍
  13. 不再害怕打字慢(python信息轰炸)
  14. 张家界和桂林的旅游纪实(避坑指南)
  15. 一些常用的软件网络端口协议分类介绍
  16. 解决台式机麦克风不可用问题,只有音频输出,无音频输入
  17. 使用MapReduce计算Pi
  18. GnuTLS error -12: A TLS fatal alert has been received.
  19. JAVA要不要看源码_为什么要看源码、如何看源码,高手进阶必看
  20. java实现简单的LUR算法

热门文章

  1. poj 2063 Investmen 完全背包
  2. React组件生命周期-正确执行运行阶段的函数
  3. 二分查找(递归和非递归实现)
  4. c# 保存和打开文件的方法
  5. Xamarin.Android开发音乐播放器
  6. 响应式web之@media screen
  7. skcket编程实例
  8. XML 文档对象模型 (DOM)细说
  9. 解决JS:window.close()在Firefox下的不能关闭的问题,兼容IE/Firefox/Chrome
  10. Java中常见的排序算法代码演示