注意 按照图分别从做到右
R1-R2-R3-R4-R5-R6
(R1-CE1)------(R2-PE1)------(R3-ASBR1)------(R4-ASBR2)-----(R5-PE2)-----(R6-CE2)
|------rip2-----| |------ospf----------|                   |------------isis--------| |-----ospf------|
跨域的MPLS,这个采用OptionA的方式互联,OptionA是采用VRF-to-VRF的方式,简单的说就是AS之间的ASBR路由器把对方相互看做是CE端,既然是VRF-TO-VRF所以必须为每个VRF创建一个连接,如果有100个VRF就的在域间创建100个VRF的连接,因此该方式的可扩展性有一定的限制,该方式主要的优点是配置和管理简单,为了满足大量的VRF,通常我们采用子接口的形式来实现域间互通。这里是采用最简化的实现方式,剔除了P路由器,呵呵我的小本本不能运行太多的路由器啊,整个PE与CE,PE与PE之间采用OSPF作为IGP协议。具体配置如下:
R1-CE1
hostname R1-CE
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
interface Serial1/1
 ip address 192.168.0.1 255.255.255.0
 serial restart-delay 0
router rip
 version 2
 network 1.0.0.0
 network 192.168.0.0

R2-PE1
hostname R2-PE1
ip vrf test1
 rd 1:1
 route-target export 1:1
 route-target import 1:1
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
interface Serial1/0
 ip vrf forwarding test1
 ip address 192.168.0.2 255.255.255.0
 serial restart-delay 0
interface Serial1/1
 de.ion To R3-PE2
 ip address 10.1.1.1 255.255.255.252
 mpls label protocol ldp
 tag-switching ip
 serial restart-delay 0
router ospf 100
 log-adjacency-changes detail
 network 1.1.1.2 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf test1
 redistribute bgp 100 metric transparent
 network 192.168.0.0
 no auto-summary
 version 2
 exit-address-family
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.3 remote-as 100
 neighbor 1.1.1.3 update-source Loopback0
 no auto-summary
 !
 address-family ***v4
 neighbor 1.1.1.3 activate
 neighbor 1.1.1.3 send-community both
 exit-address-family
 !
 address-family ipv4 vrf test1
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family

R3-ASBR1
hostname R3-ASBR1
ip vrf test1
 rd 1:1
 route-target export 1:1
 route-target import 1:1
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
interface Serial1/0
 ip address 10.1.1.2 255.255.255.252
 mpls label protocol ldp
 tag-switching ip
 serial restart-delay 0
!
interface Serial1/1
 ip vrf forwarding test1
 ip address 192.168.3.1 255.255.255.0
router ospf 100
 log-adjacency-changes
 network 1.1.1.3 0.0.0.0 area 0
 network 10.1.1.2 0.0.0.0 area 0
 default-information originate always
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.2 remote-as 100
 neighbor 1.1.1.2 update-source Loopback0
 no auto-summary
 !
 address-family ***v4
 neighbor 1.1.1.2 activate
 neighbor 1.1.1.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf test1
 redistribute connected
 neighbor 192.168.3.2 remote-as 200
 neighbor 192.168.3.2 activate
 no auto-summary
 no synchronization
 exit-address-family

R4-ASBR2
hostname R4-PE4
ip vrf test1
 rd 1:1
 route-target export 1:1
 route-target import 1:1
interface Loopback0
 ip address 1.1.1.4 255.255.255.255
interface Serial1/1
 ip address 10.1.1.9 255.255.255.252
 ip router isis cncsz
 mpls label protocol ldp
 tag-switching ip
 serial restart-delay 0
router isis cncsz
 net 00.0001.0010.0100.1000.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.5 remote-as 200
 neighbor 1.1.1.5 update-source Loopback0
 no auto-summary
 !
 address-family ***v4
 neighbor 1.1.1.5 activate
 neighbor 1.1.1.5 send-community both
 exit-address-family
 !
 address-family ipv4 vrf test1
 redistribute connected
 neighbor 192.168.3.1 remote-as 100
 neighbor 192.168.3.1 activate
 neighbor 192.168.3.1 send-community both
 no auto-summary
 no synchronization
 exit-address-family

R5-PE2
hostname R5-PE5
ip vrf test1
 rd 1:1
 route-target export 1:1
 route-target import 1:1
interface Loopback0
 ip address 1.1.1.5 255.255.255.255
 ip router isis cncsz
interface Serial1/0
 ip address 10.1.1.10 255.255.255.252
 ip router isis cncsz
 mpls label protocol ldp
 tag-switching ip
 serial restart-delay 0
!
interface Serial1/1
 ip vrf forwarding test1
 ip address 192.168.2.1 255.255.255.0
 serial restart-delay 0
router ospf 1 vrf test1
 log-adjacency-changes
 redistribute bgp 200 subnets
 network 192.168.2.1 0.0.0.0 area 0
!
router isis cncsz
 net 00.0001.0010.0100.0002.00
 is-type level-2-only
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.4 remote-as 200
 neighbor 1.1.1.4 update-source Loopback0
 no auto-summary
 !
 address-family ***v4
 neighbor 1.1.1.4 activate
 neighbor 1.1.1.4 send-community both
 exit-address-family
 !
 address-family ipv4 vrf test1
 redistribute ospf 1
 no auto-summary
 no synchronization
 exit-address-family

R6-CE2
hostname R6-CE
interface Loopback0
 ip address 1.1.1.6 255.255.255.255
interface Serial1/0
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
router ospf 1
 log-adjacency-changes
 network 1.1.1.6 0.0.0.0 area 0
 network 192.168.2.2 0.0.0.0 area 0

相关 dy脚本
autostart = false
[localhost]
port = 7200
udp = 10000
workingdir = ..\tmp\
`router R1`
    image = ..\ios\unzip-c7200-is-mz.122-37.bin
    model = 7200
    console = 3001
    npe = npe-400
    ram = 64
    confreg = 0x2142
    exec_area = 64
    mmap = false
    slot0 = PA-C7200-IO-FE
    slot1 = PA-4T
    slot2 = PA-4T
    f0/0 = SW1 1
    s1/1 = R2 s1/0
    s1/2 = R4 s1/1
`router R2`
    image = ..\ios\unzip-c7200-is-mz.122-37.bin
    model = 7200
    console = 3002
    npe = npe-400
    ram = 64
    confreg = 0x2142
    exec_area = 64
    mmap = false 
    slot0 = PA-C7200-IO-FE
    slot1 = PA-4T
    slot2 = PA-4T
    f0/0 = SW1 2
    s1/1 = R3 S1/0
    s1/2 = R4 s1/2
`router R3`
    image = ..\ios\unzip-c7200-is-mz.122-37.bin
    model = 7200
    console = 3003
    npe = npe-400
    ram = 64
    confreg = 0x2142
    exec_area = 64
    mmap = false
    slot0 = PA-C7200-IO-FE
    slot1 = PA-4T
    slot2 = PA-4T
    f0/0 = SW1 3
    s1/2 = R4 s1/3
`router R4`
    image = ..\ios\unzip-c7200-is-mz.122-37.bin
    model = 7200
    console = 3004
    npe = npe-400
    ram = 64
    confreg = 0x2142
    exec_area = 64
    mmap = false
    slot0 = PA-C7200-IO-FE
    slot1 = PA-4T
    f0/0 = SW1 4
`ethsw SW1`
    1 = dot1q 1
    2 = dot1q 1
    3 = dot1q 1
    4 = dot1q 1
    5 = access 1 NIO_gen_eth:\Device\NPF_{70DD1F0E-3BFC-4407-BC34-3956FAC819D2}

转载于:https://blog.51cto.com/steve/127344

mpls 跨域 optionA 配置实例相关推荐

  1. 基于ensp的mpls vpn跨域optionA方案(分公司之间不能互访但是能访问总部场景)

    目录 一 实验拓扑 二 实验要求 三 实验分析 四 实验配置说明 4.1完成正常ip地址配置,ISP内部使用ospf协议和mpls ldp协议 4.2 PE和CE之间起ebgp邻居 4.3 PE和PE ...

  2. vue脚手架解决跨域问题-------配置反向代理

    vue脚手架解决跨域问题-------配置反向代理 参考文章: (1)vue脚手架解决跨域问题-------配置反向代理 (2)https://www.cnblogs.com/zbx-boke/p/9 ...

  3. django允许跨域请求配置

    2019独角兽企业重金招聘Python工程师标准>>> django允许跨域请求配置 下载corsheader pip install django-cors-headers 修改s ...

  4. Nginx 指定多个域名跨域请求配置

    nginx指定多个域名跨域请求配置 什么是跨域 假设我们页面或者应用已在 http://www.test1.com 上了,而我们打算从 http://www.test2.com 请求提取数据.一般情况 ...

  5. proxy代理的使用(解决跨域,配置多个代理)

    proxy代理的使用(解决跨域,配置多个代理) 一.什么是代理 字面意思就是类似中间商,开启代理,原理就是在本地创建一个虚拟服务器,发送请求数据,同时接受请求的数据, 利用服务器与服务器间,交互,不会 ...

  6. 华为MPLS跨域C1方案实验配置

    目录 配置接域内IGP路由协议与LDP协议 配置IPv4的BGP邻居 配置PE之间的Vpnv4邻居 配置PE与CE设备对接命令 ASBR上手工为PE地址分配标签 MPLS隧道--跨域解决方案C1.C2 ...

  7. 华为MPLS跨域C2方案实验配置

    MPLS隧道--跨域解决方案C1.C2讲解_静下心来敲木鱼的博客-CSDN博客_route-policy rr permit node 10 if-match mpls-labelhttps://bl ...

  8. 华为MPLS跨域A、B方案实验配置

    目录 MPLS域内配置 MPLS-AS100域内配置 MPLS-AS200域内配置 域间方式A配置 ASBR4和ASBR5配置实例 ASBR之间建立基于实例的EBGP邻居关系 域间方式B配置 ASBR ...

  9. MPLS ×××跨域实现之OPTION B配置讲解

    MPLS ××× OPTION B配置讲解<?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" /& ...

最新文章

  1. Git 技术篇 - GitHub克隆私有仓库方法,新主机绑定并同步github私有库实例演示
  2. QT的QTreeWidgetItem类的使用
  3. HDU多校6 - 6836 Expectation(矩阵树定理+高斯消元求行列式)
  4. 各种流行深度学习构架的性能对比
  5. oracle如何改变连接属性,怎样设置navicate连接属性
  6. Git实战(二)原理
  7. 同事反馈环:如何实现持续改进的文化
  8. C#回顾 - 3.NET的IO:字节流
  9. 原来Queryable是这样实现的..
  10. es6基础(4)--字符串扩展
  11. 链表的实现 -- 数据结构与算法的javascript描述 第六章
  12. 我的PCB职业,请大家多指教!
  13. drf之day09:内置的认证类,权限类,频率类,django配置文件解析,过滤类的其他作用,全局异常处理,接口文档
  14. 虚拟现实的起源、趋势及应用
  15. 将numeric转换为数据类型numeric是出现算术溢出错误
  16. Jlink在ADS下的配置说明及常见问题解决办法 (转载)
  17. 2020-11-10总结
  18. 脑波和眼动连通性分析 python-(1)
  19. 立足中国,聚焦欧洲,蔚来汽车的如意算盘真会打?
  20. c语言中dir的用法,批处理教程:基础语法之dir命令

热门文章

  1. oracle不显示表和过程,oracle表连接——处理连接过程中另外一张表没有相关数据不显示问题...
  2. unity3d 自动变化大小_自动做游戏(1),自动生成人物侧面图
  3. qt插件开发python_Qt5 Matplotlib设计器插件
  4. python将列表写入文件_Python将列表数据写入文件(txt, csv,excel)
  5. dllregisterserver找不到入口点_厨房间漏水找不到漏水点,厨房上面漏水 | 影楼
  6. vbreport8.wpf.viewer 个别电脑不显示_【电脑手机小技巧】新买的电脑,第一次开机最好要这样设置...
  7. C#中的IO流操作(FileStream)
  8. Andrew ng清华报告听后感
  9. 麦亡9什么时候能装鸿蒙系统,距断供不到10天 麒麟9000即将绝版 华为大招来了:不止鸿蒙2.0...
  10. java word 占位符替换,javaword占位符替换